Jump to content

Twins

VIP Members
  • Content Count

    374
  • Joined

  • Last visited

  • Days Won

    3

Twins last won the day on March 20 2017

Twins had the most liked content!

Community Reputation

10 Good

About Twins

  • Rank
    I get my mail here

Vehicle Info

  • My Car
    1973 Q code Mac 1

Location

  • Location
    New York
  • Region
    Northeast

Personal Information

  • Sex
    Undisclosed
  1. Exactly what my leak was and the cure was the same. Good for you. Hopefully your problem is solved.
  2. I had a similar situation which progressed to some actual oil drips. For some time I assumed it was coming from the lower part of the engine and was expecting a big issue. As Don mentioned, in my case it was only the oil pressure sending unit located just behind the intake manifold on top of the engine. Replaced and tightened and no more seepage or leaks!
  3. Perfect.. Thanks I'll post once completed. Looking forward to seeing the finished version.
  4. here you go. Ruler and micrometer. The length is just shy of 1 1/2 inches. The micrometer has it as slightly less. Also got the height and took a measurement midway down the curve of the handle. Let me know if you need anything else. Jeff
  5. I think I read it on here when I was looking for a car five years ago! It really worked for me.
  6. Unless the 429 is different from the 351....I believe the partial VIN is stamped n the driver's side of the block in the rear by the firewall below the head. Camera or mirror work well but I cleaned the area and then took some clay and pressed it on the VIN and got an imprint. Play Doh or SIlly Putty work very well!
  7. I just realized it was Eddy that I sent a part to last year. What a gentleman...….With all the negatives associated with the internet, one of the positives is getting to "meet" people from all over the world who share the same passion. RIP Eddy.
  8. I have used Sta Bil in a variety of engines both small and large for decades. Some of those vehicles and equipment sit for months and months. Does it work? All I can say is I have never had a fuel related issue or gummed up carb problem (even on the older lawn equipment) and everything starts right up. So, I'm sticking with it. Also, on any metal gas tanks I do make sure to store them full of stabilized gas.
  9. Is that a piece of wood under the passenger side dash? Anyone notice that blue/black Mustang in the background?
  10. Sorry to hear that. It's a rush when the UPS guy drops off a part you've been waiting for and a bummer when there's an issue like that. That battery is too damn expensive to have to look at that crack! I'm sure they will replace it for you.
  11. Thanks Steve. Thats interesting. Ill bet she didnt realize it. Sent from my SM-G935V using Tapatalk
  12. I had a sneaky feeling it might be something like that. Damn repops!! Any suggestions as to what and where to get a GOOD one? Would this still be the case when under normal outside temps, it seems pretty close on the temp gauge, about 190 with a 190 stat and 14 Volts when running, 12 not running? At least I won't have to go pull the dash apart again to replace a wire. Thanks very much for your valued input. Geoff. My voltage was doing the same thing last week and replaced the VR to bring it back to 14.2v. If you dont want to buy a generic and replace the cover route, VCM
  13. Dave: Do you have the VIN number or any information about who your dad sold the car to? Jeff
×
×
  • Create New...