Jump to content

Salhi_amer

Members
  • Posts

    37
  • Joined

  • Last visited

Vehicle Info

  • My Car
    1973 Mustang Mach 1

Location

  • Location
    Katy TX

Salhi_amer's Achievements

Enthusiast

Enthusiast (6/14)

  • First Post
  • Collaborator
  • Conversation Starter
  • Week One Done
  • One Month Later

Recent Badges

0

Reputation

  1. Can someone decode this 1971 Mustang Build sheet please. Thanks, I have attached the door data plate and also tags. Thx scan0006.pdf
  2. I have this laying around, it came off my 351 Cleveland on my 73 Mach 1, worked fine, just upgraded my water pump. its free, all you have to do is pay shipping to your location. Item is in 77077.
  3. Great Mustangs showed up to the show, met WES and his beautiful car, reminded me of my Mach 1 that I sold, same year & color.
  4. seems a good price with a Q code. 3F05Q202588 1973 Ford Mustang Mach 1 http://www.hondruauto.com/inventory/1973-ford-mustang-mach-1/
  5. trust me I have $42K in her, she was a beauty, lost almost $16000 but had to let her go, it hurts a lot saying goodbye to her :(
  6. SOLD my baby today, she was at the mechanic fixing AC, brakes, suspension, etc. and got offered $26000 from someone who saw it at mechanic and deal done.
  7. Wes, its so nice to see your Marti report with the same year as mine and same color, except mine is a Mach 1. However look at color and interior description on both. Makes me wonder how accurate Kevin Marti Reports are. I will try to come to next week's show. I was out of town.
  8. ok I thought buying a new sending unit fixed my fuel gauge problem but apparently it did not. So I installed a new sending unit and still the gauge is not reading properly, on empty it read 1/2 a tank and on full it reads way past the full indicator, here is what happened, the car fuel gauge worked fine prior to engine rebuild. after rebuilding it stopped working along with the Tach, so after I brought it to a different mechanic, the 2 wires in the trunk for the fuel sending unit were cut and not even connected. now after they are connected is when this thing started happening, I have new voltage regulator, circuit board and everything works except the Tach & Fuel Gauge not reading correctly ( could these 2 be related ) Could it be a ground issue, its a brand new sending unit just installed ( my mechanic did test new unit is manually before installing it by moving it and it did read correctly on the gauge from E to F ) a So I am thinking since previous sending unit did the same thing it may be a ground issue related to those 2 wires that were cut, could you guide me on how to test the ground and trace them in trunk or anyone would suggest anything.
  9. Thank you so much, I will pass the info to the mechanic tomorrow, appreciate all the help that you give me or give other members on their problems, I always see you answering and like your answers. Thanks Dan
  10. I don't know why people customize them so much like this one I found online. It loses everything when people do this to them. Its ugly. They want $39K for it.
  11. Found this on CL not far from me. The only thing that concerns me is that the seller states that the rear passenger shock did this in the car. Is this in Panel or Frame? Is this fixable? what causes it? he said it made a bad noise with the shock but when he took out the shock and it doesn't do any sound. What is it worth? it looks it has a lot of nice options. Thanks Looks at the last 2 pics for that shock hole.
  12. Thank you, I got a member here to send me his old one since he upgraded to 31 spline. and it was the long one
  13. Ok I was curious and looked under steering column at my wires and fuse box on my 73 Mach 1 and please see picture. My tach doesn't work, does this look normal. What is the yellow wire?
  14. saw this on the way to work today in Houston and owner will take $1500 for it. Its a sprint, door data plate is missing but radiator tag shows Vin and HB trim. it looks like it needs a lot of work. Vin is 2F01H206208
×
×
  • Create New...