Jump to content

73MustangGrande

Members
  • Posts

    35
  • Joined

  • Last visited

About 73MustangGrande

  • Birthday 12/10/1992

Vehicle Info

  • My Car
    1973 Mustang Grande, 351C, FMX, coming out of 20 year sleep.

Location

  • Location
    Bradenton, FL
  • Region
    Southeast

Personal Information

  • Sex
    Male

73MustangGrande's Achievements

Explorer

Explorer (4/14)

  • First Post
  • Collaborator
  • Conversation Starter
  • Week One Done
  • One Month Later

Recent Badges

0

Reputation

  1. No, currently no updates. I haven't been doing anything to it other than drive it to work and back. Being it's running and driving, there's not really anything to do other than start making it look nice, but most of that is beyond my capabilities. Thanks for letting me know about the member map, I'll go ahead and put a pin on it.
  2. I'm running 255/60/15 on the back and 235/60/15 up front with those same size rims. At least I believe that's what the front is; might be a 235/65/15, but I believe it's a 60. They fit very nicely and help with the fact the front end on mine is pointing to the sky, so the bigger tires in the back help it out some, but I still need to work on that problem. There's room to go a little bigger in the back, but not much of any bigger up front without it rubbing the control arm.
  3. Haven't done much other than painting the car black. It's been gone over once with $1 cans of paint from Wal-Mart. It's something to make it look half-way decent. Also cut the mufflers off since they were falling apart. Actually runs a ton better, so I guess they were plugged up. Also put on some 15" Cragers from the 70's and new tires. Interesting thing that's been happening, a friend and I have been going back and forth driving it, and every time it gets back to me he says it runs absolutely terrible and he has to put it in neutral and rev it up to keep it running at lights. He even sent me a video of it running like this. I get in it, and the car runs absolutely flawless. He drove it to me, it pulled in barely running, he shuts it off, I get in and drive it around the block with no problems. Apparently the car doesn't like him even though he's more of a Ford guy than I am. He also said that he put his foot in it once to make some noise and it just stumbled and died, I came to a stop and matted it and it burned rubber just like it should. Floored it while moving and it was instant pickup just like it should. Not a clue what his problem is with it. If anyone is interested, here's a link to a short video of it we took in a parking lot. And now I learned I can put videos in posts. I just put the link, did not expect it to just put up the video here.
  4. I never thought about that. The car had sat for somewhere around 15-20 years before I got it going and all I did was check the fluid level. So the fluid is somewhere around 15-20 years old if not more. It is very dark, I just never thought anything of it since the brakes worked. I'll flush out the system and see what happens. Thanks.
  5. That is what my friend had suggested, but I don't think that would be it. I know it needs new rotors, but that wouldn't cause this I don't think. When I put the new brake pads on it, the calipers compressed very easily and were very smooth going in. It also doesn't act like a stuck caliper. It doesn't pull to one side while driving, it holds a straight line when you let go of the wheel and brake, and they're not dragging. The few times I've had brake issues over the years that were heat related, it was either the brake fluid was boiling due to air, or brake fade because of how hot they were; both of which caused a very soft pedal with almost no brake pressure.
  6. Well, as this old car gets driven more, new problems keep showing up. This is one that I have not yet experienced myself, but a friend of mine has twice now. I got my truck back running, so I put the car off to the side so I could work on it when I had the chance, but a friend's car had some issues, so I loaned him the Mustang while I worked on his car for him. Being I haven't been able to spend much time with it, I have not experienced this, but I'll tell you what I was told. He said that the brake pedal gets very hard and extremely sensitive after driving for awhile and everything is hot. When the car is cold, the brakes work as expected. But as you drive and parts begin to heat up, the pedal gets harder and eventually the lightest touch will almost lock the wheels. Now, I don't claim to be an expert in anything, but usually braking power usually goes down as stuff gets hotter (brake fade and whatnot). I know he's not trying to race the car, he won't even try to race my truck when I tell him have at it, so it's nothing he's doing. If it did it all the time, I would've replaced hoses and gone from there, but since it only does it hot, I'm not too sure where to start out. To my knowledge, it still has the original calipers, wheel cylinders, master cylinder, and brake booster. It does have new hard lines as they're nice and shiny and the old ones were in the trunk, and I would assume the rubber hoses have been replaced. The one time that I did actually check for this was when I was just told it was acting weird and I took it down the street and back with no trouble. Then today, he drove it to work with no problem, but he had to go out of the way for some stuff after and he said it started doing it after about 10 miles or so. Let it cool down and it's back to normal. I'm gonna try to get in and drive it some distance tomorrow, but I don't really know where to look as far as what would be doing this. Any ideas? Thanks for the help.
  7. That's a very good possibility. From the little that I've read, it said that a 1/4" spacer is needed for the one in the pan. I don't know if that would be the rear band or not. I also don't know if it's a special tool or anything that's 1/4" would work. Either way, I'll give it a filter change and see what happens. It doesn't smell burnt, it just seems to be dirty. Being this car has a 2.75 gear in it, I don't think anyone ever tried to race it, but you never know. I had an offer from a coworker today, and I'm gonna take it if he can get the money. But until then, I'll see what I can do. Thanks for the help.
  8. When I first pulled the engine I had to remove the torque converter with it and when I drained the fluid it was very dark red almost black. When I put it back together I put fresh type F fluid in the converter. I'll be sure to blow out the lines while I have it apart and also blow out the cooler praying I don't break it because this does need a new radiator because it's leaking due to old age. I guess the next question is should I bother with trying to adjust to the band while I'm in there?
  9. Okay, not too sure how to describe this exactly since I know nothing about transmissions, but I'll give it a try. I've been noticing that while driving around town slow, it feels like the transmission gets hung up between second and third. It'll go to shift, sound like it went into neutral because of the rpm increase, and then go into gear. I don't remember for sure, but this was either a new or a rebuilt transmission about 15 years ago that had a few hundred miles put on it before the car was parked. When I had the engine out, the torque converter had a date on it for sometime in the late 1990's, so at least that is "new". Could it just need a band adjustment and filter change? It only does it putting around. If I take off at a decent speed or really get into it, it will not do this. I don't know if this could be called slipping, it feel like it goes 2-N-3 while driving it. 1973 Grande, and like I said, I believe this to be a rebuilt trans, but it might've been new, but that was 15 years ago. I've put maybe 1000 miles on it and this is really the only issue it's given me beyond the fact the car is very slow and is turning about 3000 rpm for 70. I'd like to put an OD trans in it, but that's beyond my capabilities right now. Any and all help is greatly appreciated as this is currently a daily and my only running vehicle since I took my truck apart to rebuild the engine.
  10. Car still for sale. Have still not put on the Ford Racing valve covers, but have put on a new air cleaner and put on new white letter tires. 235/60/15 up front and 255/60/15 on the back mounted on a set of Cragers.
  11. I found some Ford Racing valve covers in the junkyard that will be going on it soon. I've been driving it around and it handles the road quite well, but does need tires. But it starts up first try in the morning and I don't need to wait for it to warm up before leaving. So far, I've put probably 50 or so miles on it and I've had it up to 70 for a couple of miles and it does very well. Although I am driving it, we are still looking to sell it, $5000 OBO.
  12. Car now has HEI distributor and I found some Ford Racing valve covers in the junkyard that will be going on it soon. I've been driving it around and it handles the road quite well, but does need tires. But it starts up first try in the morning and I don't need to wait for it to warm up before leaving. So far, I've put probably 50 or so miles on it and I've had it up to 70 for a couple of miles and it does very well. Although I am driving it, we are still looking to sell it, $5000 OBO.
  13. Car now has an HEI distributor installed. All it needs is a set of mirrors on it to drive it around and is the only reason the car has not done more than around the block. Although we don't really have the time or money for it, if it's around long enough, progress will continue slowly. Also, I had forgot to mention that the engine has been out to receive new freeze plugs and I inspected the bottom end while it was out and it is in perfect condition. Also has new timing chain and gears. Also now has new starter solenoid and main battery cable. Badly in need of mufflers; the ones on it are blown out on the ends and no longer seal where the pipes go in them.
  14. I am open to any and all offers. Please, don't feel like you'd offend me, I may accept what you want to give for it. Car will also be posted on Craigslist in the next day or two and will be in front of my or my friend's work place with a for sale sign. I just wanted to give people that are into this style of car first chance at it.
×
×
  • Create New...