Jump to content

nickstewartroc

Members
  • Posts

    48
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by nickstewartroc

  1. Awesome, thanks! I'll have to get a couple sets once the 67' is put back together
  2. Have you tried them on the 7173? I know when I did the swap to my 67 a few years back with a set of 72's I couldn't get any aftermarket pad to work as none of them had the required pin holes. It was all I could do to get a standard set that would work!
  3. So sorry to hear this Ponysnake :( I don't know what you are looking at getting for the vert' , with just buying a house I doubt I'd be able to swing much, but might be interested...
  4. What do you plan on using it for? If you use an impact wrench, I would highly suggest the 1/2 inch. Mine felt like a totally new beast from changing from 3/8 to 3/4 and can imagine that it would still be very noticeable between 3/8 and 1/2
  5. Nice! Always great to see fellow ST's out there, I have a FiST and will be flying out there August 1-2, can't wait!
  6. Looks great! When I finally get to the point of needing to replace the front end components, I'd buy a set!
  7. Would it be possible to re-post the link? It doesn't appear to work as the URL is cut off :/
  8. I used Firestone when I bought my 67' 6 years ago. Guy was real nice and very informative. Walked me through choices and what he would recommend depending on certain things. Always good customer service when going there.
  9. I'm not sure if you can have it shipped over there, but this is what I like using: http://adamspolishes.com/shop/exterior/waxing-and-glazing/adam-s-h2o-guard-gloss.html Not only does it make drying the car easier, but it adds a small layer of wax that always leaves the car feeling smooth and slick. I've tried Turtle Wax's wax as you dry and it doesn't come anywhere near what the Guard n' Gloss can do.
  10. Pinnacle Black Label Diamond Coating Elite Kit from AutoGeek. I would NOT suggest it, it's overpriced, the applicators don't work that well, and the glass protection failed in under a week. The main paint coating is alright. I recently bought a coating from AmmoNYC and their skin sealant I will be applying, comes out cheaper and should work better Sounds good Nick, What product did you end up going for? Greg.:)
  11. I put a ceramic coating on my daily driver (2016 Fiesta ST) and I love it. Most of the dirt just washes right off, it is MUCH easier to wash, when it rains is washes most of the dirt right off!
  12. Good lord, that's worse than what mines in and I paid over half that!
  13. Hi Rodney, Greetings from Mount Dora, Florida!
  14. Awesome progress! Can't wait to see the end result!
  15. That should do it! One thing you may want to look into is a detroit truetrac: http://www.summitracing.com/search/product-line/eaton-detroit-truetrac-differentials no clutches to wear out, people love em! I'll be putting one in my 67 and 73
  16. You'll need the installation kit (showed it on the right hand side as suggested too!) Also, it is not just drop in and go, there are procedures you need to go through to have proper gear lash and setting pinion depth as well as torque. A few tools you'll need are an inch pound torque wrench (for the pinion torque) and to get there you have to really torque down the nut. I used a breaker bar and cheater pipe, it needed to be tightened to around 200ft lbs so that when you use the inch torque wrench it has a certain amount of "friction" to it
  17. I wish! I won't even have gotten anywhere near starting to work on my 73! I'll be lucky if I have my 67 off the tip-over jig by then!
  18. Watched it last night, real neat movie! The only thing that bothered me is when they grouped the 65-70 mustangs with the 71-73, I always thought they were completely different, but I guess to them they are not. I can see the grouping of the newer ones together where they have similar looks, but these old beasts look so much different...
  19. Looks great! If you don't mind me asking, what color is that?
  20. Ah I see, from the way I first read it it seemed otherwise, my fault! Had you made sure the linkages are all free? I have had problems with the secondaries freezing up on my before
×
×
  • Create New...