Jump to content

shaheenk

Members
  • Posts

    102
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by shaheenk

  1. Drove it about yesterday and today , found my suspension rattle is due to brake pads, calipers . Got home to a hissing sound from the right hand side.....heater core gave up. Got her back to the shop bypassing the heater core and spent most of the morning lifiting carpets, removing the underlay and soaking coolant up from the carpets. Good news it drives.
  2. Thanks everyone who responded. I was driving the car today and gently put my foot on the brakes. Yeah rattle goes away , seems there are some rubbers for the pins on the calipers that have disintegrated over time. Guess I found my rattle , and the heater matrix gave up , now I have water .
  3. I am also thinking about a go pro or something to rig up , will take some time this week and figure it out.
  4. Pretty sure its the suspension, cannot see anything else that could be banging about
  5. Hi all , please can you assist, I have swapped out the follwing on my 73 stang 1. Lower arms , ball joints, sway bar links and bushings , shocks and ball joints. Having the car on the lift I cannot find anything that is loose, however when driving and I hit a bump or uneven surface I have a rattle which sounds like something is loose. I cannot seem to locate it and its driving me crazy . Any ideas what else or how to check this?
  6. Body shop was not happy with the way the bonnet looked. Felt it needed something extra so put some inserts on
  7. now with bumper tuck on the rear and some shots in the sun WhatsApp Video 2021-03-03 at 13.38.36.mp4
  8. @Carolina_Mountain_Mustangs @timachone Thanks guys , I will take some measurements and update on the filler panel. It was never my intention to go this route, I imported (at a stupid amount of money) a 73 bumper from the US , it took 3 months to arrive as it came in a shared container due to weight. Arrived, the bumper was torn up , the inner brace was missing and trying to get another which was in good condition would have been more then duoble the cost on the Chrome one. The rear bumper on mine is chromes aswell , while I would have loved to keep it "period correct" , there are so many other subtle changes that it made sense to bling up the front . Some of the "non standard" Wheels Interior - Seats are not using the traditional vinyl look badges are all removed side sills covers are all black anodised rear fuel cap is Mach1 front grill is Mach 1 Wiring harness is aftermarket door and dash wood inlays are now brushed alu look Engine bay painted and motor has lots of aftermarket tat on brake booster is not stock Fan shroud is not stock Electronic Ignition setup
  9. @timachone @vintageman Guys, I did it , 71-72 bumper on a 73 , no need to change fenders or brackets. We fabbed up some rough brackets to mount the chrome bumper onto the 73 arms, All credit to my panel shop for coming up with this . We will fab a filler panel under the grill to close the gap,
  10. Sorry for the delayed response , Ebay has a number of them , I like the Hirshmann stuff but trying to find one is difficult. placed on the drivers side windscreen
  11. I am using an internal Windscreen mount unit , they work well and dont need wires into the fender, The fender hole has been closed off. The boxes are sealed to the body , so fiberglass to the shape of the body then seam sealer around . The backs of them are coated in a waterproof Spectrum coat from Second skin
  12. so I know this is going to piss off the purists. I have always had a good audio system in my cars, I competed professionally for many years and stock is just not going to do it for me. With the Stang, we went for an old school approach, USD Waveguides and some 6in Midbass drivers, I wanted to keep the stock look inside with a good amount of attack and volume. We tried to look for options in terms of the 6in drivers. But went totally bonkers
  13. No worries , I have been doing some other stupid stuff
  14. Thanks , do you have any pics of your progress on the bumper since I will be doing this on a 73 as well. The bumper is a Mr Mustang unit , not sure if CJ is the same
  15. Adjusted the carb , set timing , and finally got her running where she wont switch off when put into gear. Also ordered a 71-72 chrome bumper as I could not find a 73 inner brace
  16. Hey guys so I have a double question and need some guidance 351C with 4BBL Holley 600CFM, Mild camshaft Electronic ignition setup Car starts and Idles fine , drop it into gear and she will switch off , back to N or P and she will fire up again , Could this be fuel or timing related, Have to hold the throttle and brake to get her moving along, its frustrating .Thats question 1 Question 2 , drove the car about for a while , car has a C4 with a white screw in modulator , which I understand is an early C4, I had a nightmare of a time with the previous "specialists" and this box , so I now know its all good. Checking the dipstick (I have an aftermarket one) bought from summit racing. Pan filled chrome pan as well . Pull the stick and there are loads of little bubbles in the fluid, its not a solid red. Normal or am I short on tranny fluid, I did a flush and pulled out about 3.5liters. (3.7 Quarts)
  17. Horn issue figured out, I have an aftermarket adapter kit, the contacts at the back are making contact only at certain points, so if you hold the horn and turn the wheel they come on and off. Today was speedo cable snapped .......nothing like driving along then tapping noises and you think the motor is on the way out , only to find the speedo cable broken. Have other issues as well but will post them in the engine section.
  18. Gas Gauge sorted, seems you need more then 5liters to register on the gauge and the contacts in the sender unit were not making contact. Speedo cable installed so thats working now as well. Tomorrow we trace the horns and figure out why they not working . Then Drain the oil , I suspect there is abut 2 liters too much in the motor and about 3 liters too much in the transmission.
  19. Thanks Don , I suspect its the sending unit , the ground and connectors all test our good, with me bridging them , I took a different path on the doors with the centres in brushed Alu vinyl as opposed to the wood grain.
  20. Finally got her back from all the dodgy "specialists" , went off to my paint guy who did an amazing job on it and the suspension is now sorted. Put my door panels in today , got them from Mustang garage or something, will find the name . Best quality I have seen . sorted out the brake lights which were not working , hooked up the vacume advance on the dizzy and put the grill straight , still need to sort the dizzy out , yesterday the rear view mirror went in and I have no idea why the fuel gauge is not happy , pulled it out twice , measures fine on the bench , bridge wires and it shoots to full , so might need to do that again.
  21. Thank you very much , will look into this.
  22. Went off to get the alignment sorted and check everything.
×
×
  • Create New...