Jump to content

shaheenk

Members
  • Posts

    105
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by shaheenk

  1. Hi Mac The car is completed, this was my first "american" build , I am more setup for european and Japanese cars as we have alot more of them here. The market in SA is quite different to the US where people are willing to impart knowledge , this forum has been a great source of help for me, I only found it later in my build but the help was immense. The car was not built as a restoration so a number of items were changed , modded or even dropped off. The final bit of the puzzle was done yetserday when I finally got the brakes sorted out and now it does not flat spot the rears . There is still a rattle over bumps which sounds liek transmission or exhaust or rear suspension, I will need to check it when I have time . For now it starts and drives. The person who stripped the car owes me money , he is unemployed and i know I will never see anything from it . Life goes on and we learn lessosn.
  2. My car has a sentimenal value to me , my grand father bought it for my dad before my Granddad passed away , The car stood for many years and got quite rotted out, it was my dream to build it for my dad . I did that , he drove the car , he was happy , that made me happy . When I mentioned parts , I mean in South Africa, to give you an idea my car was stripped by another person who was meant to build it , I got it back minus the follwoing 1. Interior panels 2. PropShaft 3. Gearbox 4. Torque convertor 5. Brake linkages 6. Power brake booster and Master Cyl 7. Front bumper (on a 73) 8. Windscreen 9. Wiring Harness (yes the complete harness) 10. Fuel Cap 11. Most Trim , around the windows , doors , door locks , bonnet hinges and radiator as well as bonnet catch I had to rebuild 1. Engine 2. Gearbox 3. Interior 4. Harness and electrics 5. Brakes 6. Suspension Ford does not list the bolt sizes and threads for most of their builds , so I was buying bolts and nuts (Imperial) in a country which is Metric with a hope they would fit , why because I got the car back in pieces. Its easy in the US , pop onto one of the US stores and purchase a bolt kit cool $60 , here is $60 + $60 shipping + $20 customs = $140 ....for bolts and nuts. Everything was expensive to say the least , I think I spent over $5k in shipping alone. And becuase of the above , if something goes tits up , which it usually does , I need to wait 3 weeks doing a job which should be a weekend thing. I never got the 73 bumper , so had to mod a 72 Chrome to fit. To buy a 73 bumper is easy , $150- $250 , shipping it to SA , $800. Do I love the car, no , do I like it for what it represents , yes. Would I do it again , doubt it unless I am stripping and putting it back myself.
  3. Sadly no , I dont think there is a market for them locally where I am , the parts are a nightmare to find and I find it slow and does not like the twisties very much . I get more joy from my 71 MGB GT.
  4. Drove it about yesterday and today , found my suspension rattle is due to brake pads, calipers . Got home to a hissing sound from the right hand side.....heater core gave up. Got her back to the shop bypassing the heater core and spent most of the morning lifiting carpets, removing the underlay and soaking coolant up from the carpets. Good news it drives.
  5. Thanks everyone who responded. I was driving the car today and gently put my foot on the brakes. Yeah rattle goes away , seems there are some rubbers for the pins on the calipers that have disintegrated over time. Guess I found my rattle , and the heater matrix gave up , now I have water .
  6. I am also thinking about a go pro or something to rig up , will take some time this week and figure it out.
  7. Pretty sure its the suspension, cannot see anything else that could be banging about
  8. Hi all , please can you assist, I have swapped out the follwing on my 73 stang 1. Lower arms , ball joints, sway bar links and bushings , shocks and ball joints. Having the car on the lift I cannot find anything that is loose, however when driving and I hit a bump or uneven surface I have a rattle which sounds like something is loose. I cannot seem to locate it and its driving me crazy . Any ideas what else or how to check this?
  9. Body shop was not happy with the way the bonnet looked. Felt it needed something extra so put some inserts on
  10. now with bumper tuck on the rear and some shots in the sun WhatsApp Video 2021-03-03 at 13.38.36.mp4
  11. @Carolina_Mountain_Mustangs @timachone Thanks guys , I will take some measurements and update on the filler panel. It was never my intention to go this route, I imported (at a stupid amount of money) a 73 bumper from the US , it took 3 months to arrive as it came in a shared container due to weight. Arrived, the bumper was torn up , the inner brace was missing and trying to get another which was in good condition would have been more then duoble the cost on the Chrome one. The rear bumper on mine is chromes aswell , while I would have loved to keep it "period correct" , there are so many other subtle changes that it made sense to bling up the front . Some of the "non standard" Wheels Interior - Seats are not using the traditional vinyl look badges are all removed side sills covers are all black anodised rear fuel cap is Mach1 front grill is Mach 1 Wiring harness is aftermarket door and dash wood inlays are now brushed alu look Engine bay painted and motor has lots of aftermarket tat on brake booster is not stock Fan shroud is not stock Electronic Ignition setup
  12. @timachone @vintageman Guys, I did it , 71-72 bumper on a 73 , no need to change fenders or brackets. We fabbed up some rough brackets to mount the chrome bumper onto the 73 arms, All credit to my panel shop for coming up with this . We will fab a filler panel under the grill to close the gap,
  13. Sorry for the delayed response , Ebay has a number of them , I like the Hirshmann stuff but trying to find one is difficult. placed on the drivers side windscreen
  14. I am using an internal Windscreen mount unit , they work well and dont need wires into the fender, The fender hole has been closed off. The boxes are sealed to the body , so fiberglass to the shape of the body then seam sealer around . The backs of them are coated in a waterproof Spectrum coat from Second skin
  15. so I know this is going to piss off the purists. I have always had a good audio system in my cars, I competed professionally for many years and stock is just not going to do it for me. With the Stang, we went for an old school approach, USD Waveguides and some 6in Midbass drivers, I wanted to keep the stock look inside with a good amount of attack and volume. We tried to look for options in terms of the 6in drivers. But went totally bonkers
  16. No worries , I have been doing some other stupid stuff
  17. Thanks , do you have any pics of your progress on the bumper since I will be doing this on a 73 as well. The bumper is a Mr Mustang unit , not sure if CJ is the same
  18. Adjusted the carb , set timing , and finally got her running where she wont switch off when put into gear. Also ordered a 71-72 chrome bumper as I could not find a 73 inner brace
  19. Hey guys so I have a double question and need some guidance 351C with 4BBL Holley 600CFM, Mild camshaft Electronic ignition setup Car starts and Idles fine , drop it into gear and she will switch off , back to N or P and she will fire up again , Could this be fuel or timing related, Have to hold the throttle and brake to get her moving along, its frustrating .Thats question 1 Question 2 , drove the car about for a while , car has a C4 with a white screw in modulator , which I understand is an early C4, I had a nightmare of a time with the previous "specialists" and this box , so I now know its all good. Checking the dipstick (I have an aftermarket one) bought from summit racing. Pan filled chrome pan as well . Pull the stick and there are loads of little bubbles in the fluid, its not a solid red. Normal or am I short on tranny fluid, I did a flush and pulled out about 3.5liters. (3.7 Quarts)
  20. Horn issue figured out, I have an aftermarket adapter kit, the contacts at the back are making contact only at certain points, so if you hold the horn and turn the wheel they come on and off. Today was speedo cable snapped .......nothing like driving along then tapping noises and you think the motor is on the way out , only to find the speedo cable broken. Have other issues as well but will post them in the engine section.
  21. Gas Gauge sorted, seems you need more then 5liters to register on the gauge and the contacts in the sender unit were not making contact. Speedo cable installed so thats working now as well. Tomorrow we trace the horns and figure out why they not working . Then Drain the oil , I suspect there is abut 2 liters too much in the motor and about 3 liters too much in the transmission.
  22. Thanks Don , I suspect its the sending unit , the ground and connectors all test our good, with me bridging them , I took a different path on the doors with the centres in brushed Alu vinyl as opposed to the wood grain.
×
×
  • Create New...