Jump to content

Digdugjake

Members
  • Content Count

    23
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Digdugjake

  • Rank
    Is that a Mustang?

Vehicle Info

  • My Car
    1973 Mustang Grande
    351 Cleveland 2 barrel 2 valve (for now)
    All original

Location

  • Location
    Unites States
  • Region
    Northeast
  1. After a new coil it will run for about 5 minutes and then struggle and die. Would the cause still be points and condensor? Sent from my LGLS990 using Tapatalk
  2. I tested the coil. Primary is 1.8 secondary is 9.75
  3. There is spark on initial cranking but not any more until you stop cranking. I will check the coil and condenser and get back to you. Sent from my LGLS990 using Tapatalk
  4. I am getting 12 volts closed but only .03 open. What would cause this?
  5. That makes sense but i would have to constantly adjust the dizzy to start it every day.
  6. I was planning on changing it because it has a lot of slack on either side. Sent from my LGLS990 using Tapatalk
  7. What should the voltage be open and closed? That way i know what's good and what's bad.
  8. Dont have a dwell meter but will get one on friday when i get paid. Sent from my LGLS990 using Tapatalk
  9. I havent checked voltage yet. I will do so when i get home. Sent from my LGLS990 using Tapatalk
  10. Would that have been caused by running on an alternator alone? Sent from my LGLS990 using Tapatalk
  11. It does crank. It has points. It was at tdc on compression. It just wont run. I could not set the timing with a light because it had the wrong chain in it before and now i don't want to kill my starter by cranking forever to time it. Sent from my LGLS990 using Tapatalk
  12. I ended up having to cut it off turns out it was a windsor sprocket set with a cleveland chain wrapped around it. Sent from my LGLS990 using Tapatalk
  13. A few months ago i was driving and my car just shut off. I had just replaced the alternator and put it back together and was headed to work. It would not restart and had to get it towed home. Now i have replaced the timing chain and put everything back together and it wont start. When it died the alt light came on briefly. I need this car while the other is getting some body work done in a couple weeks.
  14. In process of getting the running before spring i decided to find out if the timing chain had ever been replaced. It has with a Windsor chain. Now trying to get the sprocket and it is seized. I don't have the option to the motor due to where i live but want to get it running. It is a 73 Grande with a 351 CLEVELAND 2BBL. Any advice to get it off? Ive tried a 2 jaw puller to no effect and dont want to leave the motor open too long.
  15. The primary resistance they lost is 1.4 but when i textest it it reads 2.0.
×
×
  • Create New...