Jump to content

OzCoupe72

VIP Members
  • Posts

    650
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by OzCoupe72

  1. All looking good as usual Fabrice, great to see your progress Another suggestion for pulling out the rocker panel dent is to tack weld some largish washers along the dent line perhaps 3-5 of them Weld them vertically and run a bolt or rod through the washers then using a J hook or similar with either a slide hammer or a hydraulic porta-power gradually pull the dent out whilst tapping any high spots along the edge Once done just twist off the washers and weld up any holes if necessary I have used this method several times with great results As much as I would like a stud welder I just can't afford to buy any more fancy tools for a while due to engine/trans problems
  2. After crying in my beer for several days over my misfortune I finally got up the courage to remove my engine and do an autopsy on the damage Without completely disassembling the engine my worst fears were realized once I removed the cylinder heads to discover that number four and eight cylinder bores in particular were badly scored with number three and seven slightly scored. This would make sense with oil starvation as these are the last cylinders to get oil but why the oil starvation is still a mystery I only removed one bearing cap and the crank journal isn't too bad but the bearing shows some slight wearing There is very little debris in the sump and the oil pump looks okay I think I will leave this up to the experts and send it to my machinist for further inspection and regardless of who or what is to blame I want it fixed The only fortunate thing so far is that I have a spare standard bore block so just need to hope the crankshaft and pistons are able to be saved, regardless this will still be a costly exercise Number 4 below Number 8 below
  3. Thanks guys I think I'm starting to get used to things going wrong That's what happens when you try to do everything yourself and perhaps overlook an important detail Anyway will have a break from it for a while as funds are low Will post the forensic analysis later but suspect a spun bearing but hoping crankshaft is okay
  4. Well old mother bad luck is still following me around and it's not good After pretty much finishing my project sorting out a few bugs, dyno testing and preparing it for engineering inspections I finally organised two engineers to put it through inspections, took a day of my new job which wasn't easy, got up at 3 am, woke the neighbours starting the car then proceeded the two hour drive to Perth on a cold morning. All was going well and was enjoying its first long drive until about 40 minutes later I heard a sound coming from the engine then quickly looked at the oil pressure gauge which normally sits between 50 and 80 psi To my horror it was at 40 psi so being on a freeway I had to find the nearest parking bay which thankfully was a mile up the road By this time oil pressure was getting lower with nearly zero once I parked the car My first thoughts are unprintable on this forum however I knew it was serious so popped the hood and no sign of any oil leaks, dipstick was full and oil clean Hmm looks like I'm going to have to call the tilt tray again! Anyway $400 later and no where near getting this car passed by the engineers I'm not a happy chappy When finally home after a cold morning by the freeway I checked the oil again after it had sloshed around getting on/off the tilt tray there was color on the dipstick so my reckoning is a spun bearing so will remove the engine on the weekend and tear it down Not good, broke again and need a change of luck(or engine) Certainly not a time to crack open the champagne!
  5. Most of us forget to check every single detail, I forgot to check the alignment where the trunk meets the quarter panel extension and am out on one side so may have to repair this another time but will live with it for now I found it to be a great help prior to paint was to drill some small holes in the trunk/hood hinges once alignment was correct Didn't bother with the doors but some do Made it really easy when refitting the panels and less paint chips
  6. Welcome from Western Australia Very clean looking coupe you have there Has it been restored or is it in original condition, low miles etc?
  7. Welcome from Western Australia Nice looking vehicle and engine. should get the tires spinning easily! Perhaps post more info on the build Was this one mostly rust free?
  8. With your dual plane manifold you should be fine with a 4 hole spacer I had some vacuum/idling issues using a phenolic 4 hole spacer on my RPM Air Gap which has the notched out plenum divider Ended up getting the aluminum one below designed to use with dual plane intakes especially the air gap They even machined 1/4 inch off it to give me better hood clearance and works a treat https://pdhprecisionengineering.com.au/product/cs-4150dpl/ carby spacer.pdf
  9. Looks like a good project so far so keep us all posted and don't forget the pics A wealth of info on this site
  10. Looking good and certainly a step forward after most of the hard work is done I find putting it back together after paint quite satisfying
  11. Did you have issues with your stock pan?? I am running a 408 with stock pan without any issues. Didn't use the stock pan as it was damaged plus wanted a bit extra capacity Most of the aftermarket pans, including one I had purchased, say only for 383/393 so I ended up with a Kevko pan
  12. Today had the vehicle on the dyno and went well apart from throwing an alternator belt Had to change the carby jets and a few minor adjustments With the rev limiter set at 5900 RPM it went 362hp/270KW at the rear wheels with 1440 lbs torque This keeps me below the requirements and more than happy with its performance Sean was very impressed with the torque figure but not sure yet how to calculate this to flywheel torque Engine flywheel horsepower about 450 - 475 which is fine by me but would be good for bragging rights to get to the 500 mark Below is a video of the test and a printout Dyno test.pdf
  13. Great work and if it were me I would be complaining to those three women that their mere presence is an unwanted distraction to your important work!
  14. Could be a few things but firstly if you have taken 3/8" out of the adjustment it may have been too much and will give you a lower pedal with less brake force. I had to adjust mine twice to get it to where I was happy with it and only needed to make small adjustments to make a big difference i.e. 1/16" as the required gap between pushrod and m/cylinder piston is only 20 thou. Mine not being the original setup I couldn't advise how far the pushrod would stick out so perhaps another member can help with this otherwise you will need to remove the master cylinder again and take some accurate measurements with a vernier caliper. For example if your master cylinder piston depth is 0.300" and is flush with the mounting face then desired pushrod stick out is 0.280" however if your piston protrudes out of the cylinder for example 0.050" then you will need to subtract this from the above which would give a pushrod stick out of 0.230" Where I went wrong is the Falcon master cylinder needs to be preloaded before measuring this but don't believe the Mustang one needs this. There could still be other issues others can help with but I would first establish correct pushrod length to eliminate other causes Good luck with it
  15. Same here also 406C no clearance issues except oil pan but this won't be a problem with a 383 or 393
  16. Well for what it was worth I swapped the temp senders around today Virtually no difference in temperature with it running at a steady 85C/185F The idiot light comes on later perhaps at 82C/180F but may have got previous temp wrong Probably the only difference noted was previously with the gauge sender in the "wrong" spot at the water pump the temp went to about 92C/198F then dropped which would indicate the thermostat opening and the thermo fan coming on. Did not get this rise/fall with the gauge sender in the block although only ran it once for this So although there is a slight difference if anyone else was to use two senders just put the light only sender in the water pump which incidentally is also 3/8 NPT thread - my water pump is a Milodon alloy pump(actually GMB)
  17. I will check the heater hose set up today and report back. I have an Old Air a/c unit which has a cable operated heater valve so should be okay. From memory it wasn't blowing hot air until I put the control into the warm/hot zone Thanks EBStang for posting the diagrams it will help to understand what's going on
  18. I went with an Aussie product ICE Ignition 7 amp 1 step system which has programmable advance curves, rev limiter and vac advance So far running at 20 deg initial and about 32 deg total but will be going on the dyno next week to get it spot on Runs pretty sweet so far and happy with the product including service
  19. Interesting topic this as I have an issue with both my idiot light and gauge senders Not knowing any better I put my gauge sender into the water pump and the light sender in the usual spot Although I know for sure my engine is not getting too hot the light comes on way too early when the gauge is reading only about 140F! I realise the gauge could be inaccurate due to where I fitted the sender but considering the light shouldn't come on at 245F something is not right with the light sender which is new As an exercise to check the gauge I will swap the senders around and see if I get a different reading on the gauge which is currently reading about 180F when warmed up I suspect a faulty light sender but not being able to buy another one locally will just disconnect it for now Would be interesting to note the temp reading difference by using the water pump location which many people still use so will post results soon
  20. Looking good and no doubt you will need to bend/cut the new panel to make it fit Whether you are melting the brazing or grinding it off it is a good idea to jamb a chisel in between the panels to put a bit of tension on them Sometimes you get lucky and it pops apart Good luck with it
  21. I, like others, know how you feel having spent what's left of any retirement funds Things are so bad I had to send the missus to China by herself to visit family while I stay home and look after our first born Mustang Being near one of the most remote cities in the world and the dwindling Aussie dollar doesn't help either Thinking of starting a GoFundMe page to cover the fuel costs once I've given the Government the rest of what I can salvage from my finances just to get this vehicle on the road Oh well back to looking behind the couch(sofa) for some coins
  22. Welcome from Western Australia Don't give up on your project just persist and you'll get her done
  23. Give Seatbelt Solutions a call in Perth - http://www.seatbeltsolutions.com.au/ I bought my seatbelts from them with some nice chrome buckles, not cheap though They also supplied some anchor plates to use in the parcel shelf which should work in the sail panel area just need to rivet them in PM me if you want specific info including what ones to order for the front also with drop links
  24. Great to hear you have her back home now, must be a relief Yes it is tempting with a fresh engine to give it full noise but best to let everything bed in first Took mine for a quick spin yesterday and like yours it sure lights up the tires easy My next project will be to make some traction bars! Enjoy driving it again
  25. Welcome from Western Australia Great story about the dragonfly and like the color of your vehicle
×
×
  • Create New...