Jump to content

Valhallo

Members
  • Content Count

    367
  • Joined

  • Last visited

  • Days Won

    1

Valhallo last won the day on January 25 2013

Valhallo had the most liked content!

Community Reputation

6 Neutral

About Valhallo

  • Rank
    I get my mail here
  • Birthday 11/08/1994

Vehicle Info

  • Vehicle(s)
    73' Grande

Location

  • Location
    Utah
  • Region
    Not Selected

Personal Information

  • Sex
    Male
  1. Been a while since I've posted, but the second round of building this car has come and gone. Now I need to get rid of some parts I've hoarded and hope they can be useful to someone. New owner to pay shipping from Utah. These have been painted and will need refinishing. 16 year old me tried using rattle can chrome on the trim. 3 gauge driver panel missing 2 tabs, and a small non-visible crack on passenger panel (see pics). No scratches that would be visible after painting, and no cracks visible after installed.
  2. Welcome from Utah. Nice cars.
  3. Welcome back, and glad everyone is okay!
  4. Fingers crossed it's the pump. Based on my limited knowledge, it certainly sounds like it's the problem.
  5. Don't buy anything used without having touched it for yourself.
  6. Looks like fun was had. Lol, my car would grind on the rear wheel wells with that many people in it.
  7. I have only been running my headers with my steering box for a couple months now, and my long tubes had to be dented to fit around the box. My PS box wasn't in very good shape in the first place, but it certainly heats things up. The grease on my box likes to start smoking after a trip. Fixing that leak today.
  8. I finally have my car back with a newly painted old fender. Now its back to diagnosing some of the problems. My car has always had some clunking and vibrating issues in the power train. Whenever I go from drive to reverse or vice versa it thumps pretty hard. I pulled my slip yoke and it has a bit of play in it. Could this be my problem? I've already installed new u-joints but still have this issue. I also have vibrations when I get going above 60 and either accelerate or decelerate. I figured this was an issue with my ball joints, but have been told otherwise. Any thoughts? -Zac
  9. I don't feel left out with mine not being a Mach, but I'm not going to lie, I've never been a fan of the name Grande. I tell people mine is a Coupe.
  10. +1 to that whole post. I love the way the new challengers look. Maybe it is a younger thing.
  11. Making progress. Hopefully this third one is the ticket.
  12. Good looking coupe, but I hate the center gauge setup. Not my taste.
  13. I've only ever heard horror stories about using header wrap. I use them on my bike, but stray away from it on the car. I just used heat shields where necessary. As far as max temp, I figure they're too hot when my starter gets heat soaked. :P
  14. Jeez, this is what Christmas eve felt like when I was younger. The day is gonna drag on until that thing is done.

About Us

7173Mustangs.com is a community forum designed especially for fans and owners of the 1971, 1972 and 1973 Ford Mustang! We are not affiliated with Ford Motor Company in any way.

Site Navigation

Forums
Gallery
7173 Wiki
Blogs
Clubs

7173logo_small.png

Site Info

Founded:
July 2010

By:
Webfinity Design

From:
Latrobe, PA

×
×
  • Create New...

Important Information

We have placed cookies on your device to help customize your user experience here on 7173Mustangs.com. You can adjust your cookie settings to your preferences if you like, otherwise we'll assume that you're okay to continue.