Jump to content

n_reckless

Members
  • Posts

    78
  • Joined

  • Last visited

Everything posted by n_reckless

  1. They checked the wheels and the bearings lose or have play in them. I don't know when it was replaced before me. The shop didn't replaced last year. After checking them they said they're ok. It was September and there weren't any issues until now.
  2. Well I supplied the parts for them from Summit so I can blow the labor... I think the parts still under warranty so I'll contact them if it'll be the same after the bearings.
  3. I don't know because I took it to a shop to replace the whole front suspension.
  4. Thanks, Yes, that's what I'll do first. My main concern about the tie rod ends is that the alignment guy showed that they also have a play in them. But I hop I'll be lucky enough to solve it only with the bearings. If it'll be the tie rod ends too Is there any method to check faulty parts before installing them?
  5. I'm having some kind of strange issue with my suspension. I replaced the complete front suspension to brand new parts last September. I put around (or slightly less than) 3k miles since. I was about to set the alignment because the car is pulling to the left and having uneven tire wear. The alignment shop told me they couldn't set the alignment because I need front wheel bearings first (it wasn't changed then so probably it's time to do it...just natural wear) but the inner & outer tie rods are kind of strange to me. I almost never drive in bumpy roads and they shouldn't fail around 3k miles. They are Moog so I'd except reliability from them. Is there anybody who had issues with Moog? Is there any chance that I got faulty parts? I want to make sure to check everything before taking it apart and ordering replacements...
  6. I will replace the heater core later so wouldn't be a good idea to unhook the two hoses at the firewall (If I wouldn't cut the hoses I can still use the hoses when I put the new core in.) and hook them together with a bypass U hose? I had the same problem & chose not to pull the dash apart & replace heater core. To answer your last question: I got a 5/8" 90 degree brass elbow from local parts store and connected each hose up the this. The coolant flow stays the same and hoses are there for future use as you suggest. The join is tucked under the firewall to shock tower brace so totally out of sight. You will loose some coolant in the process but hold the hoses above the engine and this will be minimal. Check the level as normal after hot / cold cycle. Problem solved ( in the short term ) Have fun. Damn I totally forgot to check a simple brass elbow instead of a U hose and two fittings what I already ordered. That'd mean less components.
  7. I will replace the heater core later so wouldn't be a good idea to unhook the two hoses at the firewall (If I wouldn't cut the hoses I can still use them when I put the new core in.) and hook them together with a bypass U hose?
  8. I don't have the A/C hooked up, PO has removed the compressor too. I live in Florida but never had an A/C car. :D My first car was a '70 Galaxie. That one felt like a slow cooker. You just had to rub yourself with bbq rub and you're done. The Mustang is surprisingly 'cool' since it's quite smaller.
  9. Thanks everybody. You can learn something new every day. :) (I had no idea about that condenser drain before.) I will change the heater core when I'll do the cowl and floors. In the meantime I'm going to bypass it because I need the car (this is the only car I have). Technical question: After doing the bypass you have to bleed the system. Well my radiator has an outlet for reservoir which is hooked up so it's not a compeletly closed system. In this case do you really need to bleed it or it'll 'bleed itself'?
  10. Is there anybody who experienced coolant leak under the car. The exhaust manifold is dry, there's no hot engine temp./overheat when running. It appears that leaking from a little rubber nipple thing however the floor/carpet is dry so I don't think that the heater core is leaking. (The car once was an A/C car but PO removed it. I kept the heater core hooked up.)
  11. I'm running an MSD Blaster II with a ready to run dizzy. I need to check if the original wire is still connected but I don't think so. Hell, I haven't find a main power yet. Since November I'm working straight and my only day off was Christmas Day when I was able to install the amp, speakers and the receiver and my next probably will be around March when we'll finish our project and It's still getting dark early to do it when I get home. That's why I'm asking a lot and want to make sure I'd good to go hooking it up because it'd take only 10 mins and I could do it during lunch. :D
  12. Yes, I'm using the Pertronix relay but my ignition wire is disconnected.
  13. The 'I' post of the solenoid if you mean the ignition wire.
  14. Thanks, and happy new year! That was my second thought. And what about if I already hooked up a relay for solid 12V for an MSD dizzy?
  15. So the wire for the yellow/memory/constant 12v is ok to be connected together with the amps power wire. And if the remote is also hooked up I only need to connect the red/switched 12v to power the stereo. Is the ignition on the solenoid is a good place to connect it? If not what would be the best way to connect the switched 12v?
  16. The usa 630 has a remote wire. I'm asking about the main power (red) wire. If I can hook it up to together with the amps wire.
  17. The new unit is a USA-630 from Classic Car stereos. It has only one power wire for switched 12v and a yellow for the memory. in this case should a splice in the amps fused power wire would work?
  18. I just installed a stereo system with an amp and a receiver. Someone has swapped the factory receiver around the '70s to an aftermarket unit with 3 wire connection. I hooked up the new receiver and has no power. I don't have experience with electronics but my first thought is to hook up the receivers power wire to the fuse of the amps power wire. Should it work that way? I attached a photo about my idea.
  19. I know, I wanted to build the ashtray too but decided not to because I'm a smoker and It is hard to stand smoking while driving what I really like. :D But it'd be a shame to keep smoking in it. :) Well it was bolted down and but the outlines appeared only around the front section so I'm lucky :)
  20. Cool. Nice write-up. I just thought about the map light last week. I only have a block off plate instead of the light but now I can use your method.
  21. Wasn't a big deal to make it. I only used some sanding blocks, epoxy and a snip to cut a the plastic for the front then sand it to shape. It can be much easier with the specific tools for plastic fabrication but I didn't wanted to waste money for tools I'd only use once. Also this is the first time I worked with plastic so plan B was the regular shorty console if I'd screw up anything. :) But fortunately it turned out pretty nice. Like you said the Molotow airbrush would be prettier but I lack a lot of patience to mask it. :)
  22. Just finished the chrome details. If someone's having trouble with the chrome lining this works pretty well. https://www.walmart.com/ip/CHARTPAK-INC-703102-MOLOTOW-LIQUID-CHROME-PUMP-MARKER-2MM/536663923?
  23. My long console was such a bad shape beyond repairable so I've fabricated a short one from it. I'd cut the front section from the bottom side of the armrest section which has the same angle like the rest of the console all around so it was a pretty easy job with basic hand tools. I thought I'd share it if someone is in the same shoes. I thought about getting a shorty for the shifter but it turned out pretty nice and looks a little better than the factory shorty imo.
×
×
  • Create New...