Jump to content

MustangNJ

VIP Members
  • Posts

    286
  • Joined

  • Last visited

  • Days Won

    1

Posts posted by MustangNJ

  1. I know these aren't 71-73, but still thought I would share the pics. I happened to be up Pikes Peak this weekend and ran across these 2 cars. the coupe may be a 65 or so, the fast back looks like a 69-70.  the fastback was a full on restoration-mod.  I was driving a cheap rental car, and only had 1 low gear, which still caused my brakes to be 270 at the mandatory brake check on the way down. they stop you at 300.  my 4spd Mach 1 in 1st gear would have been better suited, but since I'm running OEM brakes, not sure I would have attempted the hill climb...

    mustang pikes peak.jpg

  2. you think finding out facts about your cars is hard, I have a 73 Mexican Mach 1, assembled in Mexico City. only 300 reported to have been built. crazy as it sounds, I have all the *original* dealer paperwork from Mexico City, but that still creates mysteries like: the dealer invoice shows Air Conditioning, but there are no firewall holes for A/C....and thats just the beginning. Marti is no help because of the foreign VIN...

  3. at least my new wiper blades worked....for 10 seconds until they stopped working. I think the new rubber increased drag, which blew a fuse, or the motor, or a relay...I have no idea. driving in the rain was ok above 45mph because I had Rainex on the windshield and the wind blew the beads away. slower speeds I could not see anything.

  4. I have to pick 5? when I bought my 73 Mex Mach 1 last year, it was basically a survivor, that had just barely survived. no rust, but almost no maintenance. pretty much the car was unsafe at any speed including parked. my first repairs were things that were Major issues: blew a hole in the timing cover and lost all coolant. but then I started on suspension, driveline and steering. that got the car safe. next I did crate motor, suspension( again) exhaust etc. now I have a safe, fun, dependable car. but the Next 5 things, that is the question: Next

    1. Wiring harness

    2. HVAC

    3. weather stripping

    4. seats( got to do something about the vinyl...too sweaty)....possibly replace vinyl with something else but keep stock seats

    5. blast and paint undercarriage. there is no rot, but there is some surface rust.

  5. wow. I hadn't checked this thread in a few days...it sure went sideways. I've listed cars on BaT, so I'm used to all kinds of comments...

    I haven't drive the car yet at night, but I expect the lights to be good. in the past, I've spent 3x on LED headlights, so these inexpensive ones off Ebay are an experiment.

    • Like 1
  6. I had an extra dongle that I could have connected to the indicator lights so the outer ring of the headlight would blink. I don't care for that "feature", so I didn't connect it. I think it also could have been connected to parking lights, but I opted not to do that as well. what I do need to fix is activating the buzzer that tells you the lights are left on when you turn the key off.

  7. I had to ask myself the same question this past Fall when I wanted more power. I have a 73 Mexican Mach 1, of which only 300 were made. prob far fewer with the 4spd and factory AC like mine. anyway, I knew I wanted 500-600hp. I could have the stock motor built, or I could get a crate motor. I decided on a crate 418 550hp. I'm very happy with the decision, its a great driver. I decided that my car will never be a collectible. it would need a full restoration for that, and while I have replaced/upgraded many things, the car will never be a shiny showroom piece. for that reason, the engine swap made sense for me

  8. finally got the LED's installed. they are the inexpensive Ebay ones, work great.  it was raining when I took the pics, but you get the idea. next up: windshield wipers. autozone claims to have them in stock. we will see.....

     

     

    headlights.jpg

     

    headlights2.jpg

     

    headlights3.jpg

    • Like 1
  9. found it today hanging down below the car. the plug was hanging right around where the H is in my exhaust, around the middle/front of the door.  car is running fine.  these cars are so low I can't get under the car until this weekend when I can raise it up. thanks

     

    hanging-wire.jpg

     

     

    Mustangnj,

    4 speed car ? looks like reverse light switch wiring, check if your reverse lights are working.

    Boilermaster

     

     

    yes 4spd. I'll check the lights. thx

  10. another vid cruising at about 65mph. I can't get over just how good this car is to drive now after a year of work.  I've have replace/upgraded most of the driveline, steering, suspension etc.  at 65mph there is not a single vibration and the car tracks dead straight.  the car is not nearly "done"...it needs electrical, hvac, weather stripping and a bunch of other minor stuff. the major mechanical work is completed

     

    the black box on the dash with the flickering numbers is a satellite speedometer.  it does not flicker in real life, its just an FPS thing with the video capture.

     

  11. went out yesterday driving with my son.  I had him take a couple of videos while I was driving.  the vid quality isn't great, but you get the idea.

    this stretch of road is actually fairly steep uphill the whole way, its a little hard to tell in the vid. also, you can't tell but I was hitting close to 65mph, which may or may not be well above the posted speed limit .  the car has a new 418 with less than 500 miles so I am still keeping the rpm's under 5k.  in the video, I was never on gas pedal more than 20% , and was in 2nd-3rd gear.  

     

  12. well my screws arrived from Ohio mustang supply. fortunately I was smart enough to order 2 sets of bezel screws, unfortunately I was not smart enough to order 2 sets of headlight door screws/retainers. it said "12 piece kit", but thats because the screws come in 2 colors....

×
×
  • Create New...