Jump to content

rigotti76

Members
  • Posts

    13
  • Joined

  • Last visited

About rigotti76

  • Birthday 01/01/1970

Vehicle Info

  • My Car
    71 fastback

Location

  • Location
    US
  • Region
    Northeast

rigotti76's Achievements

Rookie

Rookie (2/14)

  • First Post
  • Collaborator
  • Conversation Starter
  • Week One Done
  • One Month Later

Recent Badges

0

Reputation

  1. I didnt know that but the apron is not welded In yet. If you hot a chance do you think you could get me a picture of how the battery tray mount as mine was completely rusted away and I have no idea how the mount thanks Sent from my SM-G950U using Tapatalk
  2. Well I'd really appreciate that if it wouldn't be too much trouble! Thanks Sent from my SM-G950U using Tapatalk
  3. The front cross member look like a farmer welded it in the bent strut rod may have something to do with that Sent from my SM-G950U using Tapatalk
  4. Core support came yesterday ordered outer front frame rails today and a passenger rear apron still need to get apron extensions but I may just fix the ones I have Sent from my SM-G950U using Tapatalk
  5. Yeah, those aprons come without holes for the fenders. Looks like your right strut rod is a little bent. What are you going to do about all that surface rust? One of my buddies has a sand blaster so I had thought about going that route but it's really not bad the flash on my camera makes it look worse I think but i think a white wheel and some sanding would get me where I need to be of kinda like to avoid sandblasting as it a bit of a mess but as for the strut rod it has new bushings I guess I hadn't really thought much of it being bent is that an issue as far as aligning it goes? Sent from my SM-G950U using Tapatalk
  6. New aprons fit pretty good but will need a little massaging shouldn't be bad though kinda disappointed they dont already have the square holes for the fenders already but oh well Sent from my SM-G950U using Tapatalk
  7. I also found out my engie Is basically scap iron after removing the heads i discovered cylinder 4 had some pretty bad scoring so i stripped it down to a bear block with intentions of rebuilding it but after further inspection I found the the pistons are stamped ".060" and from what i understand that is the most you can go some say they wouldnt even go that big so I'm exploring different avenues but i am pretty much married to a small block due to my tranny and some other parts that I have sunk some money in. I'm thinking about buying a blue print 347 long block but we will see Sent from my SM-G950U using Tapatalk
  8. So I have torn in to my rust issues I'm replacing both front aprons along with the core support and portions on the rear aprons and outer frame rails in the very front I also cut open the cowl to check out the rust inside the cowl and as you can see by the pictures it is pretty bad not really sure what I'm gonna do there but I ordered everything else so I'll be able to start welding in new metal shortly looks like I got my work cut out for me haha Thanks for all the kind words and support! -joe Sent from my SM-G950U using Tapatalk
  9. I decided to clean up the engine bay and fix rust on the aprons and the cowl aswell as do some work to the engine it came out easy peasy surprisingly considering I pulled it with the trans and headers still bolted up Sent from my SM-G950U using Tapatalk
  10. Took it on its maiden voyage Saturday afternoon it was pretty sketchy but it made it to the gas station and back (about 10 miles) without any issues really. Needs an alignment and the brakes are poor at best but it was a pretty successful weekend Sent from my SM-G950U using Tapatalk
  11. Got the column and new clutch cable installed tonight having issues with it not starting without a jump even if I just shut it off gonna get a new battery and see if that's the issue the altenator is good the wiring on the other hand is kind of a mess but everything appears to be hooked up properly but I did get to take it down the driveway and back seems to shift good thanks for all the nice feedback! Sent from my SM-G950U using Tapatalk
  12. Thanks guy I just got a new steering column out of a 73 the wiring was different so I swapped over all the wiring from my column and that seems to have fixed my problem the old column was all busted up and the car would shut off when you turned the when you turned the wheels I'll get that put in after I get my new clutch cable in from modern driveline Sent from my SM-G950U using Tapatalk
  13. Hey I'm new here but I'm 21and and from Minnesota just thought I'd share with you guys my project it was a 71 302 auto I'm just about done with the t5 swap my goal is to get it on the road just the way it is for now but and just keep picking away at it Sent from my SM-G950U using Tapatalk
×
×
  • Create New...