Jump to content

Don C

VIP Members
  • Content Count

    6,895
  • Joined

  • Last visited

  • Days Won

    57

Status Replies posted by Don C

  1. Just rebuilt my 302 in my 71, .030 over with mild cam, new 4 core aluminum radiator. Temp runs about 190 but when I run it for a while it gets hot and blows coolant from the cap. Tried a 16 lb. cap and then a 13 lb. cap but no change. Any suggestions?

    1. Don C

      Don C

      I would say no, the cooling system is designed with the restriction from the thermostat taken into consideration. The popular consensus is that the coolant flows too fast without a thermostat to soak up heat from the engine. I believe that because fast flowing fluids (gases and liquids) form a  boundary layer and faster flowing fluids creates more turbulence which causes a thicker boundary layer,  effectively insulating the engine block.

    2. (See 3 other replies to this status update)

  2. Just rebuilt my 302 in my 71, .030 over with mild cam, new 4 core aluminum radiator. Temp runs about 190 but when I run it for a while it gets hot and blows coolant from the cap. Tried a 16 lb. cap and then a 13 lb. cap but no change. Any suggestions?

    1. Don C

      Don C

      New correct thermostat? New hoses? Are you sure the thermostat is installed in the correct orientation? The spring should be inserted into the intake manifold and the "bridge" should be in the coolant outlet neck.

    2. (See 3 other replies to this status update)

×
×
  • Create New...