Jump to content

Search the Community

Showing results for tags 'timing'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome
    • Introductions
    • Site News
    • Site Feedback and Problems
    • FAQ's
  • General Discussion
    • 71-73 Mustang Talk
    • Shop Talk
    • Off Topic Discussions
    • The Q & A Forum
    • Gone But Not Forgotten
    • Individual Project Build Threads
    • Glamor Shots
    • Your Mustang Walk Around
    • Concours d'Elegance
    • Marti Reports
  • Tech Forums
    • Engine, Drivetrain and Performance
    • Maintenance and Repair
    • Chassis, Body Repair, and Paint
    • Suspension, Handling, Brakes, Wheels and Tires
    • Aesthetics, Interior and Exterior
    • Electronics, Security, Audio Systems
  • Market Place
    • Rocketman's Classic Cougar Innovations, LLC.
    • Ohio Mustang Supply
    • Midlife Harness Restoration
    • Motorcity Mustang
    • Product Reviews & Feedback
    • Classifieds
  • Odds & Ends
    • Car Clubs, Shows, Cruises and Events
    • Anyone want to meet up?
    • Racing
    • Other Years of Mustangs
    • Other Vehicles
  • Steel Valley Mustangs's Topics

Calendars

  • Community Calendar
  • Default Calendar
  • Steel Valley Mustangs's Events

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


My Vehicle Information


Vehicle(s)


Location


Region


About Me


Website


Facebook Profile


Twitter Profile


Instagram Profile


Snapchat Profile


WhatsApp Profile


Sex

Found 1 result

  1. Hi all. Hoping to get a little help with a new 73 Mustang Convertible I purchased a couple months ago. New to the forum as well. Quick history on the car. This was nearly a barn find. The guy I bought it from purchased it in 2007 in California and had it shipped to Florida ( I got both the last Cali tags with the car). The car was 100% rust free and unmolested. Even all the factory air was intact. He spent a bunch of $$ on it then. I found a receipt where they went through the engine in 2007 for nearly $2500, plus they did suspension, shocks, tires, mufflers, etc. He also bought an Edelbrock RPM AirGap intake, MSD 8350 Ready to Run Dizzy and a Barry Grant Demon Carb of unspecified size. He said it never ran right and stopped registering it in 2012. The carb was off the car and in a box. The car sat since 2012 in his garage and when he went to retire he decided to sell and I bought it right. Towed it home and got to work. While draining the tank found it full of rust, so I replaced everything. Tank, lines, carb, fuel pump. I upgraded to a Holley 670cfm Street Avenger. I also replaced the radiator and got her up and running. He put the tires on in '07 and it sat in the same place for almost 10 years. When I drove it - Whump, whump, whump so on went new tires. I had to solve the notorious vapor lock problem, but all better now. I also replaced all the factory AC so she runs smooth, no leaks from the top even in a downpour and is cool inside. My AC control was broken but I manufactured parts to fix it and all is good now. Spent last weekend r&ring the quarter-glass so everything seals well now. Oil change as well! Among all the little stuff, I still need to replace the top, perhaps do exhaust and get paint! So here's where help comes in. She runs smooth at idle and drives fine, however she really lacks power. Even sitting in the garage on a hard acceleration there's a brief hesitation. I've had 2 of these 71-73 cars before all with 351c, all H code 2v motors. I just want to get the most I can without radically changing this motor as I do have another 351C in the garage from a 73 Mach1 I sold that I plan to build for beating on, the original will go full stock in case I ever want to return it to all original condition. FYI, On the Marti its a 2.75 Convention Rear axle as well, so that's some if it I'm sure. Starting with the Carb, brand new Holley Street Avenger 670 4 point adjustment. I fully readjusted the carb to the highest vacuum. Screws are about 1/2 turn out and even. If I go much more out its way too rich. Holley said 3/4 turn was a good start point. I get 21 in. HG. vacuum and this is the highest I can get. I checked, it has a 6.5 power valve and based on my vacuum should be fine. Not a carb expert, so maybe there's more I can do here. The MSD 8350 is a little unknown as it was in the car when I bought it, so wondering if maybe this is causing some issues. I have adjusted by timing light, vacuum and experienced ear. I only have the installed springs. Looks like heavy silver. And only the installed bushing (Looks like black). Its cheap to order the spring and bushing kit. Anyone running this dizzy and want to share their setup? Maybe the mechanical advance is out? Any timing info that you are using that will help is appreciated. I may consider a mild cam so any recommendations for a mostly bolt on and stock motor would be welcome. Exhaust - Its all stock at the moment. I have considered that the exhaust may be the problem. Been looking at headers (Hooker 6921) and Pypes Exhaust. Wondering if the exhaust is just putting too much restriction. Non-Performance related, I am thinking about replacing the top. I'm leaning toward canvas rather than vinyl. I know I'm going to need pads, they look original. Any suggestions on what brand and where to buy? Thanks in advance everyone. Let me know if you have any questions. Quick update: After posting this I went out and started the car. I decided to see if I lose and vacuum at speed (Indicating too much backpressure). I do lost a couple in. HG, maybe 2-3, however I also noticed it get a little rougher. Very little but still. Definitely smooth at idle and I just did a full tune up. I expected it to remain as smooth as idle. Not sure if that helps.

About Us

7173Mustangs.com is a community forum designed especially for fans and owners of the 1971, 1972 and 1973 Ford Mustang! We are not affiliated with Ford Motor Company in any way.

Site Navigation

Forums
Gallery
7173 Wiki
Blogs
Clubs

7173logo_small.png

Site Info

Founded:
July 2010

By:
Webfinity Design

From:
Latrobe, PA

×
×
  • Create New...

Important Information

We have placed cookies on your device to help customize your user experience here on 7173Mustangs.com. You can adjust your cookie settings to your preferences if you like, otherwise we'll assume that you're okay to continue.