Jump to content

New glow Shift tachometer - dodgy??


Recommended Posts

I was pretty excited when the Glow Shift tacho that I bought on eBay turned up yesterday. I thought I'd test connect it before installation in case it was faulty or something, so I wired it up under the hood - red to positive, black to negative, green to the coil negative, and tacho switch set to 8 cylinders.

 

Started the car and the tacho reads approximately three times the actual revs as can be seen by the attached picture when compared to my timing light :( The pic shows the digital read-out at about 180 (x10) and the timing light read-out at around 600 with the engine running at slow idle. Revving the engine caused the digital display to rise as expected, but still way above what it's supposed to. One by one I tried every other cylinder number setting on the gauge, but the revs displayed only got higher and higher rather than lower.

 

The only thing I can think of is that the tacho instructions say to connect the green wire to the "tachometer source wire" whereas I have connected it straight to the coil because I don't have a "source wire" available. Any suggestions??

 

I'm running a standard single point distributor, flame-thrower coil and Pertronix 1 Ignitor. From all I've read on the Net a Pertronix Ignitor shouldn't affect the operation of a tacho :shrug2:

 

tacho.jpg

Brett

phonestang2.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...