Jump to content

1973 ignition problem


Recommended Posts

My 73 is having an ignition problem. It will not rotate back to the off position or back to the ACC position. I have taken the tumbler out and put in another 73 mustang and it works fine. Took the tumbler from the other mustang and put it in my column and it locks up too. Any ideas? I have soaked it and even put some graphite down it as well.

Link to comment
Share on other sites

It might be a problem in the switch, which is mounted on top of the column under the dash, or the rod that connects the key mechanism to the switch.

 

 

“If you can't explain it simply, you don't understand it well enough.”

--Albert Einstein

 

Link to comment
Share on other sites

It might be a problem in the switch, which is mounted on top of the column under the dash, or the rod that connects the key mechanism to the switch.

 

I took the column loose and unhooked the rod from the switch on the column. Tried then to rotate tumbler back and it still won't go fully back to off position or to accessory position. Even fine it with a screw driver with tumbler out of column. No luck. Is what the tumbler sits in replaceable without changing entire column?

Link to comment
Share on other sites

I took the column loose and unhooked the rod from the switch on the column. Tried then to rotate tumbler back and it still won't go fully back to off position or to accessory position. Even fine it with a screw driver with tumbler out of column. No luck. Is what the tumbler sits in replaceable without changing entire column?

 

The problem may be in the gear at the back of the lock cylinder and its engagement/adjustment with the actuator for the ignition switch rod:

 

798410720_FixedColumn.thumb.JPG.e578246739937d0751a4592e8d66f244.JPG

 

 

“If you can't explain it simply, you don't understand it well enough.”

--Albert Einstein

 

Link to comment
Share on other sites

  • 1 month later...

I have removed the spring clips, snap ring, washer and drive gear. The actuator and rod to the ignition are moving freely but still will not move enough to allow the tumbler to go the accessory position. Could the actuator gear have slid on the rod and need adjusted? If so what is the easiest way to get it adjusted back? Thanks

Link to comment
Share on other sites

  • 8 months later...

I took the column loose and unhooked the rod from the switch on the column. Tried then to rotate tumbler back and it still won't go fully back to off position or to accessory position. Even fine it with a screw driver with tumbler out of column. No luck. Is what the tumbler sits in replaceable without changing entire column?

 

The problem may be in the gear at the back of the lock cylinder and its engagement/adjustment with the actuator for the ignition switch rod:

 

 

 

Would the same apply to a tilt steering? I am asking because my reconditioned one has arrived at customs in U.K And when i take old one out i got to strip it down because the ignition no longer works due to idiot mechanic

Steve

1971 Grande

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...