Jump to content

circuit board problems


Recommended Posts

My 1971 Mach 1 had dash light problems. In removing the dash to replace and check on things I found that the circuit board was modified from a non tach board to a tach board and they used jumper wires to connect the dash lights. I assume just getting a new tach circuit board would do the trick but the resistor seems to be right in the middle of of where the tach sits. What am I missing here?

Link to comment
Share on other sites

There's more involved...the true tach circuit card accepts a 12 pin dash cluster connector, not the standard 18 pin connector. The underdash harness has to match the dash cluster/circuit card for the wiring to be correct all-the-way-around.

 

What do you mean by the "resistor seems to be in the middle where the tach sits"? Are you referring to the constant voltage regulator?

 

Are you sure you have a Ford tach dash cluster? Are there two wires coming out of the tach pod? If not, someone inserted an aftermarket tach in there.

Let me check your shorts!

http://midlifeharness.com

cactus.jpg.92e5d9d8700abc0ed60c8ccb3426248e.jpg

 

Link to comment
Share on other sites

OK..someone earlier has replaced the dash cluster pod with a tach pod, without changing the overall dash cluster. Buying a new tach circuit card won't help as the dash cluster connector will change to a 12 pin affair and your underdash harness doesn't have that. There's more wiring changes in the underdash harness as well. Ugh...that's a mess to make correct. If it works now, leave it alone and pray it doesn't break. But you say the dash lamps don't work...look for a broken trace somewhere.

Let me check your shorts!

http://midlifeharness.com

cactus.jpg.92e5d9d8700abc0ed60c8ccb3426248e.jpg

 

Link to comment
Share on other sites

Are all the lights non-functioning? Or just around the tach? It doesn't look like there are many lights on the tach side. I see the brake light and maybe 1-2 more. These lights are SO dim already, perhaps you couldn't tell if they are working or not?

1973 Mach 1 Q-code C6 3:50

Link to comment
Share on other sites

There is a simple solution. Go to Rocketmans Classic Cougar Innovations and you can order a modified Tach and Idiot light module that fits right in. You would just need to run a ground wire to the neg side of your coil and follow the simple wiring connections. This is what I did and it works awesome. While your at it, buy a set of Hi-PO Elite LED's (NPD sells them), but do NOT put an LED in the ALT socket. This must be a regular bulb.

Picture attached. ( I do not use the brake warning light)

Rocketman is a member here also. I forgot to mention that he may take your tach as a core return if it meets his criteria.

Geoff.

 I learn something new every day!

Link to comment
Share on other sites

Thanks for the info. I was just hoping that he just put in the wrong circuit board and modified it to work. What do I look for in the dash cluster connector to see what I have there?

 

12 brass pins = 12 pin connector

 

1461793735_12pinconnector.thumb.jpg.1638dcf6b264006cf4c9921eed7a9d58.jpg

 

Does this answer your question?

Don't be afraid to try something new. Remember, amateurs built the Ark...Professionals built the Titanic! ::thumb::

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...