Jump to content

Any Holley Ultra Double Pumper Guru's ?


Recommended Posts

00m0m_7_Rs_Y18_To7s_J_600x450.jpg

 

Here is a pic of my car. I just built a 351c 4V factory iron heads with a Torker II manifold and a Holley 76750BL Ultra Double pumper carb. The carb is running too rich at idle to tune it. It is fouling plugs after about an hour of run time. I have ruled out vacuum leaks in the lifter valley and hoses. Tried tuning to increase the air bypass by opening up the secondaries with the screw on the base plate which helped but still not enough. I am pulling 13 inchs of vacuum at idle. This is a brand new carb right out of the box. The idle screws are turned out 3/4 of a turn tuned with a vacuum gauge, anything more than that and the vacuum and idle drops. I verified that the curb idle transfer slots are not open too far. I am at the point of drilling the butterflies but would prefer not to. I built this with a Howards cam and lifter kit part# MC230041-12. I don't think that this is such a radical cam profile that it should require drastic measures to tune it. I have never had a problem tuning Holley's before and I am at a stand still with this until I can get it figured out. Any help would be greatly appreciated. Thanks

Link to comment
Share on other sites

  • Replies 26
  • Created
  • Last Reply

Top Posters In This Topic

That is a nice mild cam and should not be the source of your problem. I would go to a 6.5 power valve (if it is anything else) on the primary side and jet down 2 sizes. If that helps, but doesn't fix it drop 2 more. Do not be tempted to mover faster than 2 sizes at a time.

 

What is your idle RPM right now It probably needs to be higher. I run 1000 rpm with a manual, but even an auto can need 700-750 to run smoothly with some cam and carb combinations

 

Where is your timing set at and when you look at it at 3000 rpm what is the total timing shoot for about 34 degrees total unless those are open chamber heads you can go a bit further- maybe as far as 38 Base timing will probably be best between 12 and 16 degrees-factory timing numbers are meaningless.

 

One other thing that can be a factor is running without a thermostat or a way too cold thermostat. Iron engines need to be up to temperature to work their best.

 

and finally, are you dead certain your ignition system is performing up to standards> You would be surprised at just how many carb problems are actually ignition issues.

http://www.7173mustangs.com/gallery/1_01_07_15_8_53_18.png

 

"I love my Hookers!" and "Get some Strange" probably have a different connotation to non automotive enthusiasts!

Link to comment
Share on other sites

I have already rejetted the primaries, factory jet 73 now 70. Factory power valve 6.5 now 4.5 because vacuum was at 9 until I started to tune this. Ignition system is all new with an MSD Coil and a MSD ready to run distributor. Initial timing was bumped up to 20, total 32 all in by 3500 RPM (closed chamber heads). Thermistat is brand new made especially for the Cleveland holds at 190 running. Idling at about 1000 RPM (Don't have a tach). Correct me if I am wrong but isn't the idle circuits independent of the main jets?

Link to comment
Share on other sites

If of any help, ran 25 years a similar combo with Holley 650 DP and got same issues. Rich at idle, and would sometimes ran bad after a good wot back to low rpm.

Spend time tuning, checking and replacing ignition parts etc...

 

What really made a diff were simple often overlooked details.

Ditched the paper air filter by a k&n filter. From the noise I could tell right away it was nicely breathing.

Not part of the tuning, just for the coolness of it, I bought this now classic Summit dual feed line with metal fuel filter and fuel pressure gauge,

Once installed, it was obvious I should have a fuel pressure regulator.

Running an offy dual plane intake, I've added a spacer as well.

 

Once the reg, the filter and spacer were in place, most issues were gone. (aside almost impossible restart when hot), but no more flooding conditions.

I say most because, even if it ran after that fine, its when I moved to efi that I saw how much better the same combo could run.

 

edit: forgot to add, that I never got it to run well bellow 850 rpm in park. 750-800 in drive. Probably me sucking at fine tuning carbs tho.

73 modified Grande 351C. (Finally back on the road woohoo!) 

71 429CJ. ( In progress )

Link to comment
Share on other sites

I have already rejetted the primaries, factory jet 73 now 70. Factory power valve 6.5 now 4.5 because vacuum was at 9 until I started to tune this. Ignition system is all new with an MSD Coil and a MSD ready to run distributor. Initial timing was bumped up to 20, total 32 all in by 3500 RPM (closed chamber heads). Thermistat is brand new made especially for the Cleveland holds at 190 running. Idling at about 1000 RPM (Don't have a tach). Correct me if I am wrong but isn't the idle circuits independent of the main jets?

 

You are correct that the main jetting and power valve opening point have no effect on idle mixture.

 

When you turn the idle mixture screws all the way in does the engine die?

73 conv. 460, D0VE large valve heads, Performer RPM manifold, Voodoo 227/233 cam, Holley 950 HP carb, C6 trans, 3.25 trak-loc.

Link to comment
Share on other sites

I have already rejetted the primaries, factory jet 73 now 70. Factory power valve 6.5 now 4.5 because vacuum was at 9 until I started to tune this. Ignition system is all new with an MSD Coil and a MSD ready to run distributor. Initial timing was bumped up to 20, total 32 all in by 3500 RPM (closed chamber heads). Thermistat is brand new made especially for the Cleveland holds at 190 running. Idling at about 1000 RPM (Don't have a tach). Correct me if I am wrong but isn't the idle circuits independent of the main jets?

 

You are correct that the main jetting and power valve opening point have no effect on idle mixture.

 

When you turn the idle mixture screws all the way in does the engine die?

Doesn't die but runs rough. Also the mixture screws aren't consistent when turned in, 3 of them have a definite effect on idle the other 1 has a minimal effect which seems to me to indicate an internal leak but I have replaced all the metering block and fuel bowl gaskets.

Link to comment
Share on other sites

I have already rejetted the primaries, factory jet 73 now 70. Factory power valve 6.5 now 4.5 because vacuum was at 9 until I started to tune this. Ignition system is all new with an MSD Coil and a MSD ready to run distributor. Initial timing was bumped up to 20, total 32 all in by 3500 RPM (closed chamber heads). Thermistat is brand new made especially for the Cleveland holds at 190 running. Idling at about 1000 RPM (Don't have a tach). Correct me if I am wrong but isn't the idle circuits independent of the main jets?

 

You are correct that the main jetting and power valve opening point have no effect on idle mixture.

 

When you turn the idle mixture screws all the way in does the engine die?

Doesn't die but runs rough. Also the mixture screws aren't consistent when turned in, 3 of them have a definite effect on idle the other 1 has a minimal effect which seems to me to indicate an internal leak but I have replaced all the metering block and fuel bowl gaskets.

 

 

Remove the carb and check how much of the t slot is exposed on both the primary and secondary.

73 conv. 460, D0VE large valve heads, Performer RPM manifold, Voodoo 227/233 cam, Holley 950 HP carb, C6 trans, 3.25 trak-loc.

Link to comment
Share on other sites

I'd also check your float height, it may be too high and dripping out the boosters. The engine should die when you close the idle mixture screws. If it doesn't and the float adjustment is correct, you might have an internal leak which would be a warranty issue.

 

If I have issues setting a four corner idle carb, I close the secondaries and get it sorted on the primaries, then work the secondaries back in.

 

Don't ever assume the carb is good, Holley's QC has failed me in the past. I recently purchased a replacement baseplate for a friends HP carb. The secondary shaft was bound up internally and nearly impossible to move. summit swapped it right out, but good thing I checked it before doing anything.

 

 

Link to comment
Share on other sites

Update: I removed carb and pulled it down, changed power valve back to 6.5 now that I'm getting 13" of vacuum. Jets are now 70 on the primary's and 73 on the secondary's Drilled all 4 butterflies with .130 drill bit. Now idling with 15" of vacuum. Idle screws have a profound effect on the idle. They are adjusted out 1 1/4 turns now. I haven't changed a plug yet to see what it looks like since I changed the setup. I am waiting for it to cool down now. I think this did the trick. I still need to look at the timing again and see if I can back it down some. I set the floats first thing. Thanks guys for taking the time to consider my problem. I hope this helps someone else that might be having the same problem. I will update this thread with any new info. Thanks again.

Link to comment
Share on other sites

Look forward to hearing a positive report!

http://www.7173mustangs.com/gallery/1_01_07_15_8_53_18.png

 

"I love my Hookers!" and "Get some Strange" probably have a different connotation to non automotive enthusiasts!

Link to comment
Share on other sites

I'd also check your float height, it may be too high and dripping out the boosters. The engine should die when you close the idle mixture screws. If it doesn't and the float adjustment is correct, you might have an internal leak which would be a warranty issue.

 

If I have issues setting a four corner idle carb, I close the secondaries and get it sorted on the primaries, then work the secondaries back in.

 

Don't ever assume the carb is good, Holley's QC has failed me in the past. I recently purchased a replacement baseplate for a friends HP carb. The secondary shaft was bound up internally and nearly impossible to move. summit swapped it right out, but good thing I checked it before doing anything.

 

I know what you mean about Holley QC. I didn't mention it before but when I first pulled the fuel bowls off I found that they were kind enough to leave me an extra float pivot screw inside the bowl that was jammed in the needle and seat mechanism. I took care of that and it ran a little better.

Link to comment
Share on other sites

Update: I removed carb and pulled it down, changed power valve back to 6.5 now that I'm getting 13" of vacuum. Jets are now 70 on the primary's and 73 on the secondary's Drilled all 4 butterflies with .130 drill bit. Now idling with 15" of vacuum. Idle screws have a profound effect on the idle. They are adjusted out 1 1/4 turns now. I haven't changed a plug yet to see what it looks like since I changed the setup. I am waiting for it to cool down now. I think this did the trick. I still need to look at the timing again and see if I can back it down some. I set the floats first thing. Thanks guys for taking the time to consider my problem. I hope this helps someone else that might be having the same problem. I will update this thread with any new info. Thanks again.

 

Do all 4 corners now act the same? I believe the Ultra has screw in idle channel restrictors. If so, one may be larger than the other three, seen it before. The restrictor hole being too large may have been the problem to begin with. They typically ship with too large of a restrictor hole for street cars and modest cams, the last 4 Holley HPs have been this way. The cam having a relatively tight 108 LSA, compared to a 110 or 112, will have more overlap, roughen the idle, and lower the vacuum at idle. The idle quality is decreased as compression is lowered as well. I hope all is well at this point. Chuck

Link to comment
Share on other sites

I and others (stanglover) have had issues with holleys and have had to drill holes in the butterflies. Ours were with the street avengers though. I had same issues with a 770, and the other was with a 670. Sounds like a Holley deal cause since I switched to a different carb my car is running better than ever.

I guess I should also add these aren’t the double pumper carbs, but sure sounds like very similar problems.

John - 72 Q Code

Link to comment
Share on other sites

Update: I removed carb and pulled it down, changed power valve back to 6.5 now that I'm getting 13" of vacuum. Jets are now 70 on the primary's and 73 on the secondary's Drilled all 4 butterflies with .130 drill bit. Now idling with 15" of vacuum. Idle screws have a profound effect on the idle. They are adjusted out 1 1/4 turns now. I haven't changed a plug yet to see what it looks like since I changed the setup. I am waiting for it to cool down now. I think this did the trick. I still need to look at the timing again and see if I can back it down some. I set the floats first thing. Thanks guys for taking the time to consider my problem. I hope this helps someone else that might be having the same problem. I will update this thread with any new info. Thanks again.

 

Do all 4 corners now act the same? I believe the Ultra has screw in idle channel restrictors. If so, one may be larger than the other three, seen it before. The restrictor hole being too large may have been the problem to begin with. They typically ship with too large of a restrictor hole for street cars and modest cams, the last 4 Holley HPs have been this way. The cam having a relatively tight 108 LSA, compared to a 110 or 112, will have more overlap, roughen the idle, and lower the vacuum at idle. The idle quality is decreased as compression is lowered as well. I hope all is well at this point. Chuck

Yes, all 4 corners are acting the same now. All channel restrictors are machined in the blocks. Not changeable. I think I will be able to tune it now. I just need a few days to work it. I will let you know what I run into. Thanks.

Link to comment
Share on other sites

I and others (stanglover) have had issues with holleys and have had to drill holes in the butterflies. Ours were with the street avengers though. I had same issues with a 770, and the other was with a 670. Sounds like a Holley deal cause since I switched to a different carb my car is running better than ever.

I guess I should also add these aren’t the double pumper carbs, but sure sounds like very similar problems.

Sounds like the same issue. I don't know what is up with Holley anymore. Used to be able to buy one off the shelf a be very close on tune. I did read that they have reengineered the fuel curve on some of the new carbs. Sounds like they messed up the idle circuits on them.

Link to comment
Share on other sites

Do you have Brass floats?  If so try replacing those, as I have heard stories of the same issues when people have leaking floats.

 

Replace them with the rubber floats.

 

kcmash

Link to comment
Share on other sites

OK this is were I'm at now. I changed a plug and set the initial timing to 16 degrees, curb idle vacuum at 13", 1 1/4 turns out on idle mixture screws. Pulled the plug that I had changed and it is still too rich. Plug is dark brown. It is better than it was but still not optimum. I am going to drill the butterflies out to the Holley spec of .150 on the kit they sell. They are drilled at .130 now. Everything I have done and found so far has helped a little but not fixed the problem. If this doesn't fix the problem then I will probably have a custom carb built specifically for this combo or switch to fuel injection.

Link to comment
Share on other sites

OK this is were I'm at now. I changed a plug and set the initial timing to 16 degrees, curb idle vacuum at 13", 1 1/4 turns out on idle mixture screws. Pulled the plug that I had changed and it is still too rich. Plug is dark brown. It is better than it was but still not optimum. I am going to drill the butterflies out to the Holley spec of .150 on the kit they sell. They are drilled at .130 now. Everything I have done and found so far has helped a little but not fixed the problem. If this doesn't fix the problem then I will probably have a custom carb built specifically for this combo or switch to fuel injection.

 

 

Did you drive the car before the plug check or is this just idling?

 

Have checked to see how much t slot is exposed front and rear?

 

What size are the ifr's?

 

What size are the iab's and are they clear, meaning not plugged?

 

How are you determining the 1 1/4 turn mixture screw setting?

 

Do you have a pcv valve hooked up?

73 conv. 460, D0VE large valve heads, Performer RPM manifold, Voodoo 227/233 cam, Holley 950 HP carb, C6 trans, 3.25 trak-loc.

Link to comment
Share on other sites

you may still need to lean out idle circuit, insert a strand of copper wire about .010 dia. 1/2" long bent like letter J and slide long end into idle feed jet in the metering block. this will have a noticeable effect on idle and cruise mix. i remember on my 429 that .013 wire dia. was too lean and caused surging at cruising speed. i did this on a 3310-2 750 cfm vac sec. and a 850 dp w/4 corner idle, only on the prim metering block

Link to comment
Share on other sites

  • 1 year later...

Update: I removed carb and pulled it down, changed power valve back to 6.5 now that I'm getting 13" of vacuum. Jets are now 70 on the primary's and 73 on the secondary's Drilled all 4 butterflies with .130 drill bit. Now idling with 15" of vacuum. Idle screws have a profound effect on the idle. They are adjusted out 1 1/4 turns now. I haven't changed a plug yet to see what it looks like since I changed the setup. I am waiting for it to cool down now. I think this did the trick. I still need to look at the timing again and see if I can back it down some. I set the floats first thing. Thanks guys for taking the time to consider my problem. I hope this helps someone else that might be having the same problem. I will update this thread with any new info. Thanks again.

HELLO SCACER 1.  HOPING YOU HAVE THINGS SORTED OUT WITH YOUR CARB.  I PLAN ON USING THE SAME HOWARDS CAMSHAFT AND A 750 OR 780 HOLLEY 4150 SERIES OF SOME SORT.  I WAS WONDERING IF YOU HAVE BEEN ABLE TO "TRY OUT" YOUR COMBO YET, AND HOW IT PERFORMS.  I WILL BE USING MINE IN A 73 COUGAR CONVERTIBLE, C6 2500-3000 STALL 3.89 GEARS.  THANKS!

Link to comment
Share on other sites

Update: I removed carb and pulled it down, changed power valve back to 6.5 now that I'm getting 13" of vacuum. Jets are now 70 on the primary's and 73 on the secondary's Drilled all 4 butterflies with .130 drill bit. Now idling with 15" of vacuum. Idle screws have a profound effect on the idle. They are adjusted out 1 1/4 turns now. I haven't changed a plug yet to see what it looks like since I changed the setup. I am waiting for it to cool down now. I think this did the trick. I still need to look at the timing again and see if I can back it down some. I set the floats first thing. Thanks guys for taking the time to consider my problem. I hope this helps someone else that might be having the same problem. I will update this thread with any new info. Thanks again.

HELLO SCACER 1.  HOPING YOU HAVE THINGS SORTED OUT WITH YOUR CARB.  I PLAN ON USING THE SAME HOWARDS CAMSHAFT AND A 750 OR 780 HOLLEY 4150 SERIES OF SOME SORT.  I WAS WONDERING IF YOU HAVE BEEN ABLE TO "TRY OUT" YOUR COMBO YET, AND HOW IT PERFORMS.  I WILL BE USING MINE IN A 73 COUGAR CONVERTIBLE, C6 2500-3000 STALL 3.89 GEARS.  THANKS!

Sorry I haven't posted in awhile. Got frustrated and gave up on it. The plan at this point is to drill the butterflies to .150, and add the wire restrictors, then go up 1 step hotter on the plug. The headers are open right now and at this point I am wondering if I have a reversion problem. Any thoughts? :huh:

Link to comment
Share on other sites

scacer1,

 

How old is that carburetor? I have had Holley's tuned and tuned just to discover that they had internal cracks causing vacuum leaks. If your budge allows, chunk the Holley and get you a FiTech system. I have the FiTech Go 400 and just love it!

 

https://fitechefi.com/products/30021/

 

 

Fitech.png

Thanks,

mustang7173 🇺🇸

"Courage is being scared to death but saddling up anyway" -- John Wayne

Link to comment
Share on other sites

scacer1,

 

How old is that carburetor? I have had Holley's tuned and tuned just to discover that they had internal cracks causing vacuum leaks. If your budge allows, chunk the Holley and get you a FiTech system.  I have the FiTech Go 400 and just love it!

 

https://fitechefi.com/products/30021/

 

Brand New out of the box. The Holley Ultra series uses billet aluminum metering blocks so I don't think that is the problem (Although there could be an internal crack in the main body). Also I put a different carb on it and it is still fouling the plugs. That is why I am thinking that this is a reversion problem. I would rather try to get this tuned than to chuck a brand new carburetor, but it may come to that if I cant get this tuned right.

 

 

Fitech.png

Link to comment
Share on other sites

It's my experience that open headers cause a lean condition. How long are you running it and at what RPM before you read the plugs?

 

 

“If you can't explain it simply, you don't understand it well enough.”

--Albert Einstein

 

Link to comment
Share on other sites

It's my experience that open headers cause a lean condition. How long are you running it and at what RPM before you read the plugs?

 

I haven't gotten it out on the the road yet, I am trying to get it so that it wont foul the plugs at idle. The reason I am thinking it is a reversion problem is the cam has a 108 degree LSA so it has a lot of overlap. I might have to go out and run it hard to see if that cleans up the plugs. I know that high performance carbureted cars in the past would foul plugs at idle but once they were opened up the plugs would clean up and run hard.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...