Jump to content

brake light came on


Recommended Posts

I drove the car for the second time this year. I had driven about a block from the house and the brake light came on. I stopped and pump the brake a few times and it went off. I check the master cylinder and the fluid level was ok. No sign of any fluid on the driveway or in the street. I drove it again about 2 hours late no light and no sign of any leaks. Bad brake light switch ???  Or something else? I have a new master cylinder and booster.

 

 

John J

Link to comment
Share on other sites

To adjust the rear shoes you should just back up and put the brakes on hard. The self adjusters should take car of it. Do several times. Has to be hard enough to rotate the adjuster. If you took them off I would suggest you put back on they work fine. You should put a little disc brake lube on the moving parts and on the backing plate where the shoes ride on the edge.

I always put both feet on the pedal and push as hard as I can before I leave the garage. If a line ready to blow or cylinder I want it to happen in the garage.

Blew the rear crossover line couple days ago bleeding brakes on the 73. I made new one yesterday.

When a man is in the woods and talks and no women are there is he still wrong??:P

David

Link to comment
Share on other sites

Sounds like the brake proportioning valve could be bad too. That is the unit that causes the brake light to come on when brake pressures are not the same in all lines. There is a rod/piston inside that unit that is usually centered in the valve body. If the pressure is higher on one side if forces the rod to move off center and the light to come on. There are springs inside that can get gummed up that prevents the rod from centering after it ages. There are rebuild kits available or you can just buy a new one. When I went 4 wheel disk I had to change my disk/drum one to disk/disk and they run around $100 or so and make sure you get the right one. The other unit to suspect is the master cylinder, there are rebuild kits for that too. There is also a rod with a couple of o rings that can wear and cause pressure going to the proportional valve to be higher on one side than the other. There are two lines from the master cylinder going to the proportional valve, one line to each side of the piston and the pressures should be equal. I would check the master cylinder first and then the proportional valve.

-john

(jbojo)

351C 4V cc heads, 10.5 : 1 CR, 290 Herbert cam, Flat top forged pistons, forged connecting rods, Atomic efi,

C6 with Gear Vendor overdrive, 3.89 Tru Trac, Hooker Super Comp with 2 1/2" Pypes Exhaust.        

 

Some Mod pictures can be seen at: [button=http://www.7173mustangs.com/forum-garage?filterxt_uid=2026]Bojo's Garage[/button]

 

 

Link to comment
Share on other sites

  • 1 month later...

I'm with jbojo, in that I think your proportioning valve stuck off-center for a moment, and likely will be o.k. , but you may want to remove it and clean it out to prevent it from re-occurring. You did the right thing by pumping the brakes, as that's what the shop manual says to do to center the valve. Sometimes, when replacing the front disc pads, if you compress the piston back into the caliper too fast you can move that proportioning valve piston off-center which activates the little white nylon switch that is screwed onto the valve...….it happens, no big deal. Just pump the brakes , the valve centers, and the light goes out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...