Jump to content

C-6 trans


Recommended Posts

new engine 408c, 13.5 to 14 of vacuum at the manifold and at the vacuum modulator. transmission is C-6 from performance automatic. when you drive it easy, it upshifts early and seems to slip before it go in drive. if you stop and take off and give it more gas [ drive it harder ] it shifts fine. stop it, pull it back in low, manually shift it, its ok. 60mph floor it, drops to 2nd and don't let off it upshifts fine. called performance automatic said it needs 15 of vacuum at the modulator, to shift properly, if not need to go with a manual valve body and shift it manually. they said adjust vacuum modulator first , go in 3/4 to 1 turn and play around adjusting it and see if it fixes it. ideas ? am I getting told a line of crap? I did go in 3/4 a turn was no help. letting car cool off and turn it in some more and see if it helps. when engine was stock it shifted fine.

Link to comment
Share on other sites

When higher amounts of engine vacuum act on the modulator, the transmission begins to shift earlier and softer. As engine loads increase vacuum diminishes, causing the transmission to shift later and more firmly. Adjusting the modulator will help with shifting. It sounds like you need to turn the screw in some. Turn clockwise to firm up and delay the up-shift of the transmission. Turn the adjustment screw in a counterclockwise direction to speed up and soften the up-shift. Do one turn at a time and test drive. Do not adjust the screw more than 3 turns in either direction.

  • Like 1

Kilgon

 

 

"The only dumb question is the one not asked"

Link to comment
Share on other sites

reset the timing and the carb. getting 15 to 15.5 in of vacuum now. adjusted vacuum modulator again when in 1 turn, drove car didn't see much of change. let it cool off, went in 1 more turn drove car, a little better. adjust some more latter this week, see what happens

Link to comment
Share on other sites

  • 3 months later...

If the modulator wasn't pre-adjusted when fitted it is not unusual to have to go in 3-4 turns . The correct setup is to adjust on a set of scales to a set tension. I use the values given by transgo.

Adjusting the modulator does alter line pressure a small amount and can tidy up that 2-3 flare

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...