Jump to content

Grounding issue I think


Recommended Posts

Question ole wise ones, all my lights flicker when the car is running, with the car off and lights on there is no problem. Only when engine is running. Problem is with all lights, headlights, maker lights and the interior lights.

 

Amy ideas?

Link to comment
Share on other sites

Voltage regulator or worn brushes or slip rings in the alternator.

 

It could also be loose connections on the alternator or regulator.

  • Like 1

 

 

“If you can't explain it simply, you don't understand it well enough.”

--Albert Einstein

 

Link to comment
Share on other sites

Not sure what you mean by interior lights too?  The dash illumination or something else?

 

My bet is on a defective headlight switch.

 

kcmash

Link to comment
Share on other sites

Looks like the wiring that goes to the voltage regular has seen its better days, there is no more insulation for about an inch on any of the wires where it plugs into the regulator.

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...