Jump to content

Recommended Posts

All,

 

Need some assistance.  My front blinkers in my 73 vert quit working.  details:

 

All lights work, including front parking lights.

 

Rear blinkers work

 

Emergency flasher work (front and rear)

 

Left and right turn signal indicators in dash work including the audiable clicking

 

The only thing that doesn't work is the front blinkers.

 

Could this be a bulb issue on both even though the parking lights work?  I was going to replace the flasher relay, but does that not control both front and back?

73 H Code Convertible

Link to post
Share on other sites

That's a dual filament bulb, did you swap the bulb with the one on the other side?

Link to post
Share on other sites

That's a dual filament bulb,  did you swap the bulb with the one on the other side?

 

No, I've not actually done anything with the bulbs.  I just went out one day and the front blinkers no longer worked.

73 H Code Convertible

Link to post
Share on other sites

I meant, did you swap the bulb with one that works, to see if the problem moves? Then you could yell if it's a bulb issue

Link to post
Share on other sites

I meant, did you swap the bulb with one that works, to see if the problem moves? Then you could yell if it's a bulb issue

Ah sorry,  No both front blinkers are not working.   I am going to pickup new bulbs and see.  Just seems odd that they would both quit at the same time.

73 H Code Convertible

Link to post
Share on other sites

If the 4 way flashers work but the turn signals do not up front, then the problem is more likely in the turn signal switch itself, rather than in the bulbs, sockets, or wiring forward of the firewall.

  • Like 1
Link to post
Share on other sites

If the 4 way flashers work but the turn signals do not up front, then the problem is more likely in the turn signal switch itself, rather than in the bulbs, sockets, or wiring forward of the firewall.

Thanks, I'll check that out as well.

73 H Code Convertible

Link to post
Share on other sites

If the 4 way flashers work but the turn signals do not up front, then the problem is more likely in the turn signal switch itself, rather than in the bulbs, sockets, or wiring forward of the firewall.

Thanks, I'll check that out as well.

 

Ok, so an update.  My vision is apparently screwy... I could have sworn the flashers worked, but I checked them again and no front flasher and the rear just flashes fast.  So I appears to be the fuse.  That makes me feel better as when I thought everything but the front blinkers worked, I was getting a little worried.  Got new flasher unit arriving tomorrow so I'll hope that cures it.  Otherwise, I'll keep running down the other fuses, etc... on donw the line.

 

Thanks everyone for the help.

73 H Code Convertible

Link to post
Share on other sites

If it were the fuse, none of them would work. When you have fast flashing it's generally because other bulbs on the same side are burned out or power is not getting to the bulbs, bad turn signal switch, bad connections, bad bulbs, or bad grounds.

  • Like 1

 

 

“If you can't explain it simply, you don't understand it well enough.”

--Albert Einstein

 

Link to post
Share on other sites

Any time you are into the bulbs and sockets clean the contacts with steel wool or sandpaper and apply the electrical grease to stop the corrosion. It works on boat trailers and campers and also cars. You local parts house will have it I think the last I got was made by permatex.

  • Like 1

When a man is in the woods and talks and no women are there is he still wrong??:P

David

Link to post
Share on other sites

Any time you are into the bulbs and sockets clean the contacts with steel wool or sandpaper and apply the electrical grease to stop the corrosion. It works on boat trailers and campers and also cars. You local parts house will have it I think the last I got was made by permatex.

 

Thanks,

 

I have a new relay coming and some new bulbs.  Going to replace everything and clean all connections and see if that fixes it.  Otherwiese I'll investigate the wiring.

 

Trouble shout the issues one at a time I and eventually I'll find it.  I appreciate everyone's help!!

73 H Code Convertible

Link to post
Share on other sites

Any time you are into the bulbs and sockets clean the contacts with steel wool or sandpaper and apply the electrical grease to stop the corrosion. It works on boat trailers and campers and also cars. You local parts house will have it I think the last I got was made by permatex.

 

Thanks,

 

I have a new relay coming and some new bulbs.  Going to replace everything and clean all connections and see if that fixes it.  Otherwiese I'll investigate the wiring.

 

Trouble shout the issues one at a time I and eventually I'll find it.  I appreciate everyone's help!!

 

Problems (2) solved.

 

Thanks everyone for your help.  Turns out I had a two fold problem.  Not sure if one led to the other, but both are cured now.

 

1st... The front blinker... I did have a bulb with the blinker filliment out.  Not sure how I missed that but oh well.  Blinkers work now.

 

2nd... The emergency flashers were still flashing fast.  So I replaced the relay in the glove box and all is well now.

 

This forum has been extremely valuable to me so thank you everyone who shares their knowledge and experience.

73 H Code Convertible

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...