Jump to content

Recommended Posts

Finally got to 90 degrees in the sun yesterday here in Kansas so I got out the boot to see if I could get it to fit. In early May i tried and would have sworn there was absolutely NO way it would ever fit.  Well, after it got good and warmed up, it was a struggle but i finally got it on. Took me nearly 30 minutes but here it is. 

My wife and I went out to have ice cream for supper after I finally got it on. It even stayed on in the wind. I was very happy.

boot.jpg

 

boot2.jpg

 

first-time-Booted-6-4-20.jpg

  • Like 1
Link to post
Share on other sites

Does this boot have extra padding underneath? It does not look as "Boney" as some I have seen where you see the frame.

Link to post
Share on other sites

Looks great. Nice looking vert too!!

73 Grande H Code. Headman long tube headers, T-5 Transmission, 3.70 Traclok, Lowered 1" all around, Aussie 2v heads w/ 2.19 intake, 1.71 exhaust, screw in studs, full roller cam 608/612 lift 280/281 duration LSA 112, Quick Fuel 750 CFM double pumper, AirGap intake.

 

- Jason

 

 

082-hot-rod-power-tour-2017-1970-1970s.jpg

 

Link to post
Share on other sites

Hi,

 

I had the same issue with my new boot also but finally got it 'stretched' on last summer. My boot came with some very thin foam pieces to place over the latches to protect the boot. I still haven't decided whether to 'glue' them on or just place them over latches before putting on the boot. I might go a bit thicker or just double up this set of foam.

Link to post
Share on other sites

Sir, that is a gorgeous vert!!

Link to post
Share on other sites

The boot came with 1/2'' foam pads that I glued in with contact cement. 

 

Thanks to all for the compliments. Took  the boot back off today to put top back up. Top and boot both need to stretch and get broke in.

 

Wayne

Link to post
Share on other sites

Looks really good. Car looks great too. I'm a big fan of red. It's amazing what a little heat will do. Had the similar issue when doing my seats. Swear the upholstery was to small but let it sit out in the sun for awhile and what a difference it made on getting it on.

Kilgon

 

 

"The only dumb question is the one not asked"

Link to post
Share on other sites

I have a white and black boot. The black boot  heats up faster and is much easier to put on then the white one. I think the white one fits a little better.

 

IMG-1790-a.jpg

 

image uploader

 

IMG-1945.jpg

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

About Us

7173Mustangs.com is a community forum designed especially for fans and owners of the 1971, 1972 and 1973 Ford Mustang! We are not affiliated with Ford Motor Company in any way.

Site Navigation

Forums
Gallery
7173 Wiki
Blogs
Clubs

7173logo_small.png

Site Info

Founded:
July 2010

By:
Webfinity Design

From:
Latrobe, PA

×
×
  • Create New...