Jump to content

Recommended Posts

Just took delivery of my beautiful 1971 Mustang convertible all original car. Delivered to UK from new. Been under wraps for most of the last two decades runs and drives perfect . I have a problem with the front Right indicator though . It works on the hazards and the side light but not when I indicate. The light comes on the panel and the rear but nothing on the front. I’ve replaced the bulb but to no avail ,Any help greatly appreciated , regards Chris

Link to post
Share on other sites

I believe that it is the turn signal switch. Each direction on the switch has two contacts, one for the rear lights and one for the fronts.

 

 

“If you can't explain it simply, you don't understand it well enough.”

--Albert Einstein

 

Link to post
Share on other sites

Thanks I’ll take a look tomorrow , Thought it might have been a short somewhere as the flasher unit not working when I turn right but the rear stays on instead. Thanks for your time I’ll let you know how I get on .

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...