Jump to content

Recommended Posts

Ok guys bear with me on this one. The p/s reservoir's was leaking on my 73 where the big o ring is. So i changed just the o ring and the rear seal because  everything else was working fine.   After putting everything back together and doing the air bleed procedure the steering was hard as a rock. I tried all sorts of stuff, turning the wheel left to right and even pulling a vacuum on the reservoir.  No change. So this car has the p/s cooler. I pulled the return line going from the cooler to the pump started  the eng. and let some fluid pump out into a drain pan. Next I pulled a vacuum  at the p/s cooler return line to see if I could get the air out of the system.  After doing all of this and topping off the fluid it seems to be working fine, you can turn the wheel with one finger like before. So there had to be a big air pocket stuck in there someplace.  My thing is I've never seen this procedure for air bleeding the system done anywhere. ( and believe me I googled everything on the subject  ). Just wondering if anyone has ever had this problem before or was it just a fluke.  This thing drove me crazy for a couple of days.

Link to post
Share on other sites

I've never had that problem, but it's nice to know there's a solution. Thank you for sharing it with us.



“If you can't explain it simply, you don't understand it well enough.”

--Albert Einstein


Link to post
Share on other sites

Good to know, Im going to be changing the box and lines so Im going to have to bleed the system on mine too. I know in the past with my old foxbody i just had the front off the ground and went lock to lock with the car off a bunch of times, then fired it up and did the same. 

Link to post
Share on other sites

I really think it was a fluke. I've never had that problem before, but yea it's good that there is a solution if it happens again.

Link to post
Share on other sites

After receiving my rebuilt PS box from powersteering.com, it mentioned in the bleeding instructions that if air gets into the system, it can cause "air-bind" which is no power steering assist.

The instructions given to fix that were:

remove the pressure hose from the back of the pump, push a very thin straight pick into the pressure port hole to release stuck flow valve, push the pin in about 6 times, reattach the pressure hose and refill the reservoir.

Havent tried this technique so maybe someone else can verify it, just passing on instructions.


Link to post
Share on other sites

What you are pushing with the pin is the relief valve. If it gets stuck it will bypass the fluid directly to the reservoir. The idea is to get it unstuck. It may be worth to examine the port to make sure there are no debris inside it or that it is not scored.

Sent from my SAMSUNG-SM-G930A using Tapatalk



1971 M-Code Mach 1 w/Ram Air, 408 stroker, 285/291 0.558" roller cam, Blue Thunder intake, TKO600, Hooker headers with electric cut-offs, FiTech EFI w/ RobBMC PowerSurge pump

Strange center section with Truetrac, 3.5 gear and 31 spline axles, 4-wheel disc brakes

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

About Us

7173Mustangs.com is a community forum designed especially for fans and owners of the 1971, 1972 and 1973 Ford Mustang! We are not affiliated with Ford Motor Company in any way.

Site Navigation

7173 Wiki


Site Info

July 2010

Webfinity Design

Latrobe, PA

  • Create New...