Jump to content

Recommended Posts

What is the best location for an electric fuel pump?

Probably go with Holley as the '71 M-code has a Holley carb.

 

mike

 

 


spacer.png

Share this post


Link to post
Share on other sites
Posted (edited)

As low and as close to the tank as possible, AND clear of the exhaust, not easy on our cars, the way the exhaust is routed. You may have to manufacture an heat shield.

http://www.crankshaftcoalition.com/wiki/Mounting_an_electric_fuel_pump

Edited by Don C
more information

 

 

“If you can't explain it simply, you don't understand it well enough.”

--Albert Einstein

 

Share this post


Link to post
Share on other sites

What DonC said. Mounted mine to the rear frame rail with a rubber bushing. on the outside as the exhaust runs inside. My biggest complaint is the noise. I tried several and the Holley was the quietest. You'd think they could make a quiet pump. 😞

 


 

My_Vert_Signature.jpg.be46b029936118552aebff3a5a6ae997.jpg

1973 Convertible : 351C, FMX, Factory AC, PS, PB, 2.75 Rear Ratio

 

Share this post


Link to post
Share on other sites

I have heard that the Holley pumps can be very hit or miss. The shop I got a bunch of stuff from today said they warrantied 2 Holley pumps last week and sometimes they just seem to make a bad batch.

Share this post


Link to post
Share on other sites

I ended up using a Holley Mighty Might like this one:

https://www.amazon.com/Holley-12-426-Mighty-Might-Electric/dp/B00JS18DXS/ref=sr_1_1?dchild=1&keywords=holley+mighty+pump&qid=1592743149&sr=8-1

The Mighty Might sometimes is silent and other times it sounds like a jackhammer. I think its louder when less fuel is consumed and the pressure is higher like at start up. But honestly sometimes I dont hear it and other times I do. Was overall better than the Holleys or Carters and just $50.

I tried the Carter which seemed to have a reputation as the quietest but I couldn't stand the whine. I also mounted it on rubber so thats what got left in unless I find something better. 


 

My_Vert_Signature.jpg.be46b029936118552aebff3a5a6ae997.jpg

1973 Convertible : 351C, FMX, Factory AC, PS, PB, 2.75 Rear Ratio

 

Share this post


Link to post
Share on other sites

That pump is rated to support 300 HP and that may be optimistic. I don't know about your engine so it may be fine. Chuck

Share this post


Link to post
Share on other sites

I'm sure that's optimistic but I'm stock at the moment and not trying to be crazy. I tried the Carter which was supposed to be quiet and the whine was loud even with rubber mounts so I returned it after realizing the Holly was quieter. I think because I have a vert and the noise comes in through the trunk/top storage area.  Still searching for a higher quality *QUIET* pump. I just put a new tank in. If I knew 2 months ago what I know now, I would have done an in tank pump. Now I'm too lazy to pull the tank, drain it, wash it so I dont blow something up while cutting, and spend $200+ . I thought about buying a new tank but this one is 2 months old 😞

 


 

My_Vert_Signature.jpg.be46b029936118552aebff3a5a6ae997.jpg

1973 Convertible : 351C, FMX, Factory AC, PS, PB, 2.75 Rear Ratio

 

Share this post


Link to post
Share on other sites

Why did you go to an electric pump? If you want no motor whine go back to a mechanical pump. Chuck

Share this post


Link to post
Share on other sites

Thanks Chuck,

The issue was Vapor lock to the point the car would die after a few miles in 80 degree weather. This car has AC. In the Florida heat my under hood temps were high, but operating temps are normal. 

To answer the next questions this generates - I replaced the Radiator, thermostat, flushed the system. Engine cooling isn't an issue. I have an all new fuel system and placed a phenolic spacer as well as a Holley heat shield and line shields and still had the issue. I tried 2 different mechanical fuel pumps. I tried both metal and rubber fuel lines from the pump to the carb. Whenever you touched the metal line between the pump and the carb, it was HOT!

The mechanical pump was always hot to touch and was warming the gas. The AC components not only generate more heat, but also restrict under-hood air flow. My car has the stock hood, not the NACA which I think has more clearance plus you can open the vents up if needed (This is a planned change when I paint).

The combination of Ethanol fuels, high road heat, high fuel pump temps, crappy under hood airflow all seemed to contribute, no one item alone seemed to solve it (Ask me how I know). The fuel bowls didn't get overly hot, it was the fuel in the lines vaporizing. Vapor lock is caused by a low boiling point and low pressure lowers the boiling point, so pulling fuel vs pushing makes it worse. 

What ultimately solved the issue was a combination of things that keep my fuel cool and I haven't had any issues, even in the last several days of 100+ temps. I removed the mechanical pump  to stop the low pressure and parasitic heat. I replaced it with an electric pump right at the fuel tank to push the fuel (and pressurize it). In our cars there are 2 metal fuel lines to the pump. The first ends right inside the firewall and is connected with a short piece of rubber tube to the second metal line that exits the engine bay and runs near the drivers front wheel and in to the mechanical. I cut that second circuit out. I connected to the end of the first metal line near the firewall and ran to the carb from the rear of the engine where there is less restricted airflow.

LOL, you asked!

 


 

My_Vert_Signature.jpg.be46b029936118552aebff3a5a6ae997.jpg

1973 Convertible : 351C, FMX, Factory AC, PS, PB, 2.75 Rear Ratio

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

About Us

7173Mustangs.com is a community forum designed especially for fans and owners of the 1971, 1972 and 1973 Ford Mustang! We are not affiliated with Ford Motor Company in any way.

Site Navigation

Forums
Gallery
7173 Wiki
Blogs
Clubs

7173logo_small.png

Site Info

Founded:
July 2010

By:
Webfinity Design

From:
Latrobe, PA

×
×
  • Create New...

Important Information

We have placed cookies on your device to help customize your user experience here on 7173Mustangs.com. You can adjust your cookie settings to your preferences if you like, otherwise we'll assume that you're okay to continue.