Search results

Help Support 7173Mustangs.com:

  1. K

    Rear glass trim install help needed

    MAKE SURE you are using the correct clips. Earlier Mustangs used a heavier guage clip and steel trim. They look the same, but the aluminum trim on a 71 is about half the thickness and therefore a lighter clip that will work on the aluminum. AMK Products Front Window Molding Retainer Clip Set...
  2. K

    New problem, engine randomly dies, no spark

    Do you have a picture of your Duraspark installed? If it fits with my Ram Air, I will put it on my wish list. I would plan to put the module in the right side headlight box.
  3. K

    New problem, engine randomly dies, no spark

    I am really thinking I am undersized on the Jets. This carb is the 86670 Part # 0-86670BL. This has 63 Jets in the primary and 73 in the secondary. I am thinking I should go with 66 in the primary. Your Thoughts? kcmash
  4. K

    New problem, engine randomly dies, no spark

    Hemikiller, Thanks for the reply. I need to check jet sizes. I have been thinking it is fuel related. Even the last engine had fluctuation at highway speed(same carb here). With this engine I am at a totally different cam, and it is acting the same. What size do you suggest for primary...
  5. K

    New problem, engine randomly dies, no spark

    So the backfiring is gone with a new coil and the new condenser. Idle is good, acceleration good. Now I am still experiencing fluctuation power when cruising. At 2200 to 2500 rpm in 4th gear I am at 55 to 65 MPH. The Tach holds steady, but the car has random surging in the power. If I...
  6. K

    Gas tank sending unit replacement

    I replaced my original with a reproduction. First year of driving one of the contact pins fell off. I put my original back in. Kcmash
  7. K

    New problem, engine randomly dies, no spark

    Sounds similar to my problems. 1) I found the connection above the brake pedal, ignition switch to main harness was loose. 2) I was told to get a blue wire condensor. Standard motor products FD77. I also replaced my coil. Have not started it since putting the condenser and coil on it, so I...
  8. K

    Electrical issue in engine circuit

    Talked to a points/condenser guru yesterday. He said to be sure to go with a blue wire condenser versus a black wire. I had never heard of this, so I bought the Standard Ignition FD77. It was amazing how much larger, heavier, and more robust it appeared than the black wire condenser. I also...
  9. K

    Electrical issue in engine circuit

    I checked the dwell with an engine analyzer. It was a solid 23. Kcmash
  10. K

    Electrical issue in engine circuit

    Yep, mine is like a 5 year old Holley Street Avenger 670. I entry replaced the power valve and it made no real difference. Based on the latest info I am pretty sure it is the ignition system. I am running standard points and and old Ford Coil. Gas problems may case a car to bog and die or...
  11. K

    Electrical issue in engine circuit

    Holley 670 Ultra For the Carb. I did some research and really feel the coil is my problem. 1) The failure is random, and electrical 2) Coils can show signs of: a) loss of power/poor performance b) intermittent misfires c) random backfiring My car has had some variable power...
  12. K

    Random Shutdowns with a BANG!

    Good suggestion. I replaced the engine feed wire(yes that has water temp, oil and +coil) because I had repaired my original at the coil terminal due to breakage. I thought that might be the problem on Saturday when she backfired, I thought maybe I had high resistance there or an inconsistant...
  13. K

    Random Shutdowns with a BANG!

    OK, I am needing more help with the kcmash Mach 1. Today, I retorqued the Edelbrock aluminum intake, and replaced the engine feed wire with a new reproduction. Found a couple vacuum lines had lost their caps, so I replaced those. I start the car up and she runs good and sounds good. Then a...
  14. K

    Electrical issue in engine circuit

    Well, I am thoroughly embarrassed at all the things that keep me off the road. Was heading out Saturday night, and I get a big old backfire then she idles like crap. Still have more of a shake than I like at idle, so I am afraid I have a vacuum leak or something. Not sure why nothing works on...
  15. K

    Electrical issue in engine circuit

    I know what it is now! What would make the car and everything suddenly die! Not even a click from the ignition after dying, no power at all! Well it happened again tonight. What I found is my toe is hitting the ignition switch wiring at times and it all goes dead. Tonight when it died I...
  16. K

    Hood scoops 71 Mach 1

    I don’t have any Ford Documentation on that, just personal experience. When we had these cars as daily drivers in the 80’s, several of us opened the scoops up. I had one friend lose his hood on the highway as the primary latch failed, the hood flew open and buried the back of the hood into...
  17. K

    Hood scoops 71 Mach 1

    From what I have seen you should make sure your hood latch is in good shape when opening the scoops. That does cause an up force on the hood at speed that can damage or fail your primary hood latch over time. That is one of the reasons all Ram Air cars have the twist locks. They are a...
  18. K

    Electrical issue in engine circuit

    Midlife, I get a super clean tone and low resistance when I check continuity on all my ground connections and positive connections. It’s hard to tell if the radio is tied to the ignition problem or not. The ignition misfire is definitely tied to the car being warmed up, By warmed up I mean...
  19. K

    Electrical issue in engine circuit

    Ok here we go again 351 c 4 speed car, fresh restoration, fresh engine. Holley 670 Ultra, Edelbrock Performer II LB intake. Autolite distributor with points, original engine feed wire. The car starts and runs good, and idles well. Under lighter acceleration around 49 mph, there is a little...
  20. K

    Starter Gremlin

    Ok. The battery was good. The terminals were not fully cleaned. So it starts again. I did find a loose connection at the alternator too. So that probably caused some of the issue.
Top