351C 2v - smoke issue

7173Mustangs.com

Help Support 7173Mustangs.com:

73FastBk

Well-known member
Joined
Oct 12, 2020
Messages
68
Reaction score
16
Here the quick back story

Back in 2003 my dad and I bought a used 351C and had it completely rebuilt. I was planning on swapping out the 302 for the 351 in 2004 but I ended up going to college and life got in the way. Fast forward till now.... I took the car to the shop for the swap which included the c6 Tranny. The engine idles perfectly fine and starts right up.

but... once you turn it on, it starts blowing blueish smoke on the left exhaust (no H pipe) It takes about 1 minute warming up before it blows smoke. Do y’all think it’s the valve stems? I figure they might have  dried up after not running for 18 years. I have videos of it as well

 
Last edited by a moderator:
Joined
Jan 1, 2012
Messages
8,213
Reaction score
959
Location
Springfield, OR
My Car
1971 Mustang Sportroof M code
If it was rebuilt with umbrella seals that is a possibility. Another possibility is rust and/or frozen rings. easy enough to pull the valve cover.

After that I would start with a compression test of all 8 cylinders.

Another possibility is the intake gasket is leaking,

 

73FastBk

Well-known member
Joined
Oct 12, 2020
Messages
68
Reaction score
16
If it was rebuilt with umbrella seals that is a possibility. Another possibility is rust and/or frozen rings. easy enough to pull the valve cover.

After that I would start with a compression test of all 8 cylinders.

Another possibility is the intake gasket is leaking,
Thank you  very much, I will look at those options before having to tear it apart. I just want to make sure I do everything else before pulling the engine out. Thanks again  :34713505_1:

 
Top