High beams light indicator

7173Mustangs.com

Help Support 7173Mustangs.com:

Joined
Aug 14, 2014
Messages
3,620
Reaction score
556
Location
Madison, WI
My Car
1971 M-Code Mach 1 w/408C stroker
I am trying to find the circuit or wires that feed the high beam indicator in the instrument panel - the one with the horse in the tach. I can't find it in the wiring diagrams. Mine stopped working last year. The bulb seems fine but the light is not turning on anymore so I need to troubleshoot it. Any advice will be appreciated.
 

midlife

Shorts checker
Joined
Jan 24, 2012
Messages
4,123
Reaction score
547
Location
Tucson, AZ
My Car
No Mustangs at the moment.
It is a green/black wire that goes to the dash cluster connector. How do you know that the bulb is OK? Check the traces on the circuit card to see if there is a break there for the signal and for the ground lead.
 
Joined
Aug 14, 2014
Messages
3,620
Reaction score
556
Location
Madison, WI
My Car
1971 M-Code Mach 1 w/408C stroker
It is a green/black wire that goes to the dash cluster connector. How do you know that the bulb is OK? Check the traces on the circuit card to see if there is a break there for the signal and for the ground lead.
Thanks. Tonight I will try to light up the bulb to triple check. It will be an easy fix if that's the problem.
 
Joined
Aug 14, 2014
Messages
3,620
Reaction score
556
Location
Madison, WI
My Car
1971 M-Code Mach 1 w/408C stroker
So I am embarrassed to say that it was the bulb holder. I wired it directly and it was not turning on. I had already tested several bulbs and nothing. The contacts in the holder had separated and they were not making contact. Now they are closer together and working again. I should have checked that before posting.😖
 

Latest posts

Top