LED signal light flasher issue

Help Support 7173Mustangs.com:

Joined
Apr 2, 2021
Messages
97
Reaction score
36
Anyone have issues with installing LED signal light flashers?

For whatever reason either 1) my car is wired backwards, or 2) the Chinese got there production process backwards.

So I bought 2 LED flashers: one for signal lights and one for the emergency hazard 4 way lights.

They are simple plug and play devices (so I thought).

Started with the signal lights above the glove box and then moved to the 4ways located under the dash by the fuse box.

I plugged in directly and they didn’t work....

thought about it...ended up building a set of jumpers to cross the connectors.

low and behold with the connections crossed (with picture of the jumpers I built) both signal lights and 4ways work as they are supposed to....

what am I missing?   Is this normal?

I am curious if anyone else has had this issue

thx as always for your comments

330C6435-C038-4AD3-B7A9-916F5BC2C0D3.jpeg

 

midlife

Shorts checker
Joined
Jan 24, 2012
Messages
4,079
Reaction score
496
Location
Tucson, AZ
My Car
No Mustangs at the moment.
LED's are often polarized, and I've read that some LED flasher cans are reversed polarity from the factory and need to be reversed for our cars.

 

NOT A T5

VIP Members
Joined
Jul 19, 2016
Messages
1,949
Reaction score
62
Location
Omaha, NE
My Car
1971 Mustang Convertible
I had the same issue, just reversed the wires on the connectors!

 
Joined
Sep 12, 2015
Messages
5,768
Reaction score
880
Location
SW Ontario
My Car
1971 Mustang Mach 1, M code, 4 speed.
There has been many posts on this before. 

In my case, I bought ALL my LED lights and flashers from Bill at HiPoParts.com. The flasher needs to be grounded as well as being correct polarity. My factory wire harness was also wired backwards, but, this did not matter back in the day because polarity was not a concern. I did not have those little gismos to remove small pins from the socket, so I made up short jumper wires to connect the flasher. See pic.

Early on, I tried LED bulbs etc. from Amazon, epay or the local parts store and ended up scrapping it all. Cheap junk! then I found a member here, Bill at https://www.HiPoParts.com He supplies much better components and his service is awesome. He will assist with any questions or problems you have. HiPoParts is located in Michigan. Check out his website. 

IMG_0178.1.JPG

 
Last edited by a moderator:
Top